Scroll

Analyse FAQ

Analyse FAQ

Follow
Summary Analyse FAQ
Applies to Askia Analyse
Written for Beginners
Keywords FAQ; frequently; asked; questions; begin; first; steps; analyse; askiaanalyse; mean; scaled values; rating; speed; weighting, weight, converge; invert; inverted data; 64-bit; Col sig; LOI; duration, time; tab style; tab template; format; layout; calculation; script; library; AnalyseLib.mdb; NPS; Net Promoter; numeric; standard deviation; algorithm.

Table of contents:

 

How can I make my tables run quicker?

  1. Work on local drive and not on network: If the connection between your network and your pc is slow, it will be quicker to work on a local copy of the files and then update the network copy of the files when done.

  2. Export or select only the required data: e.g. Create a sub-population of only completes and then export this sub population into a new file to work with. Alternatively, if you are in a .qew (Surf file), you can go to the 'Edit' menu in Analyse and select only the waves of data that you need to report on. This will save on the amount of processing required by cutting out the records you don't want.

  3. Invert database: This tool in Askia Analyse treats the data in a different way once you have used it. Rather than read it respondent by respondent it reads it variable by variable. In order to do this, the option will create a .dat folder in the same location as your .qes file. This is useful for studies where you have many hundreds or thousands of respondents.

  4. Compact and repair in tools: If you have removed interviews or questions in the .qes file the size of the database will not be reduced until you compact and repair.

  5. Use the 64-bit version of Analyse: The 64-bit version of Askia Analyse is defaulted by default. You can access it by navigating to C:/Program Files (x86)/Askia/64bit.

  6. Disable intermediary results: In Analyse, go to Tools > Options and change the "Generate intermediary results when calculating col-sig" option in the General section to "No"

  7. Increase the maximum number of threads: In Analyse go to Tools > Options and change the "Max number of threads" option in the Portfolios section and increase this number.

  8. Disable logging of run times: In Analyse go to Tools > Options and change the "Log run timings" option in the Portfolios section to "No"

  9. Ignore col-sig: In Analyse go to Tools > Options and change the "ignore col-sig to improve speed" option in the Portfolios section to "Yes"

  10. Disable weighting report: In Analyse go to Tools > Options > Weighting and change the "Write a report after each weighting" option to "No"

  11. Use the option in Surf, 'Improve Metadata Speed': Full explanation can be found in this article.

 

Weighting does not converge error. What does this mean and how can I fix it?

  • A weighting convergence error can occur for a number of reasons:
    • when your weighting scheme falls outside the minimum or maximum bounds set in the weighting options.
    • In order to converge, the weighting algorithm needs to iterate more than is allowed by your settings.
    • You are attempting to weight a grouping to a target which is impossible e.g. the grouping has zero counts and you are weighting it > 0
    • Less common, the weighting never actually converges beyond a certain number of decimal places accuracy. For this, you can reduce the accuracy setting

 

  • When experiencing a weighting convergence error, the most likely solution will be to change one of these weighting options in Analyse, Tools menu > Weighting > Options

 

 There is a more detailed document for troubleshooting this error message here

 

How can I find the duration of my interviews in Analyse?

  • In Analyse go to Edit > Create a Variable and set the Type to "From Entry Duration".
    • You can drag & drop specific questions or choose "add all the questions" into the variable.
    • The value of the time taken by the respondent to cover the questions selected will be displayed in seconds.

 

What is a tab template and what is the difference between saving in the library and in the survey file?

The tab template is the feature that governs most of the formats, settings, calculations and scripting that are used on your tables. 99.9% of these settings are not survey or variable specific.

Saving the Tab Template to either the .qes / .qew or your Library will depend entirely on your usage. A tab template saved in your .qes / .qew is denoted by a grey box / disk icon. A tab template saved in your library is denoted by a blue and green globe icon. 

Saving the Tab Template to the .qes file provides anyone who has access to that .qes the ability to use the saved template.

Saving the Tab Template to your Library allows you to use that template across multiple .qes and .qew files. You can set the path to you AnalyseLib.mdb library file in: Tools menu > Options > Library > Library path. If your AnalyseLib file is on a shared directory then multiple users can connect to the same library file.

Tab templates whether library or data file based are also saved in the portfolio and so all the settings can be transferred in these. You don't need to create a tab template to use a portfolio, just open the portfolio (this loads the correct settings) then save the tab template with a new name.

 

How do I change the styling of my tables e.g. the colours, fonts, borders etc?

  1. Select the element in the element list, or simply click the element in the table. Note that the table element list allows you to select all elements in a particular category (e.g. all column titles).
  2. Use the formatting toolbar to change the font, font size, font emphasis (bold, italic or underline) of the element, as well as the text color and background color.
  3. Repeat this process for each table element you want to change.

You can find more information about this process via the following online assistant page: http://analysishelp.askia.com/style_of_table_analyse

 

How do I create a weighting from a numeric variable storing a weighting factor per respondent?

In the weighting menu, select the box [...] next to 'Initial weight question' > Search for your numeric variable and hit OK:

 

The distribution window in the bottom-left hand corner has disappeared / is blank. How do I restore it?

If you notice this section on the bottom-left of Analyse disappear, you more than likely accidentally hit the "minimise" arrow, as shown in the yellow-highlighted area in the above screenshot. 

If you notice the bottom-left being empty or blank, bring your mouse to the same highlighted area, left-click with your mouse, and drag either up or down to either expand or minimise the size of the window. See below GIF:

      

 

 

How do I create a table to show NPS (Net Promoter Score)?

One method to do this is described below:

  • Firstly, select the variable you wish to use to create your NPS score, and select 'Add calculated response'

  • In the dialogue that appears, insert this script:
(({11}+{10}) - ({1}+{2}+{3}+{4}+{5}+{6}+{7}) ) / ({1}+{2}+{3}+{4}+{5}+{6}+{7}+{8}+{9}+{10}+{11})*100
  • Ensure that 'appears like a stat calculation' is selected. It should appear thus:

You can dictate how many decimal points appear by selecting "Number Formatting"

  • Compile and ensure there are no errors. When you open your Results tab, your NPS should appear.

 

How do I show a mean score and the analysis (scaled) value in my caption for a numeric / rating scale variable?

If you have a rating scale question e.g. Excellent, Very good, Good, Fair, Poor. You might choose to assign numeric scale values to each code in order to show a mean score, for example.

The scaled values to create numeric calculations can be applied in Design or Analyse (by manually entering or pasting factors).

Sometimes it's required to show the scaled values 100, 75, 50, 25, 0 in the response caption along with the rating. The quick way to do this is to double click on your variable in the rows, for example, to enter into its properties. Once there, you can enter the following keywords to automatically amend the caption for each response: %c (%v) - please note, in order to show calculations such as mean score, standard deviation etc you have to have 'Allow calculations for numerics' ticked:

The result is as follows:

 

Is there a description of the weighting algorithm?

You can find a document here which goes some way to describe the algorithm and gives useful background info on weighting and convergence.

 

 

 

 

 

 

Have more questions? Submit a request

Comments