Scroll

myView: Simplifying questionnaire structures in Analyse

Follow
Summary This document introduces the myView functionality which helps sharing files between various users (e.g. technical and non-technical) by enabling simplification of questionnaire structure saved in one or more .mlv. It is similar to a 'Package' in askia Vista.
Applies to Askia Analyse.
Written for Data Processors, Analysts, Researchers, Statistical Analysts.
Keywords Indent, calculated variable, developed questions, zero based, questionnaire structure, grouped response, calculated response, re-order, my limited view, mlv, back colour.

 

What is myView and why do we need it?

'myView' is an alternative view of the questionnaire tree in Analyse. In this view you can: 

  • Re-order questions
  • Hide questions
  • Re-order responses
  • Hide responses
  • Change overall structure / indent & create chapters
  • Change captions of questions and responses
  • Create grouped or calculated responses which are assigned to questions in the myView questionnaire tree.

Here are some examples when it might come in useful:

  1. .qes or .qew files with long structure e.g. when the data file has lots of loops or historic questions and has become difficult to navigate through. 
  2. Files shared between a data processing (DP) team and researchers can contain many variables that are not needed by the researchers. This can create a confusing experience for them when they use the shared data file.
  3. A data file might have sections of it allocated to different researchers e.g. country specific sections. A different .mlv file can be supplied to each team to show only the profile of questions they will be dealing with.

 

How do I get started creating a .mlv (my limited view) file?

Firstly, we would recommend you go into the Tools menu in Analyse > Options > myView and set yourself a myView back colour. This will let you easily differentiate between your normal Analyse questionnaire tree and your myView questionnaire tree.

To create a new myView file go to the File menu > New myView.

You will find a tab now available to toggle between 'myView' and 'Questionnaire'

This tab the current myView will disappear if you go to File > Close myView. If you have made a change, you will be prompted to save the definition (.mlv) file. If you want to save at any time without closing, simply press the disk button in the tool-bar towards the top:  

When you save, the default .mlv file name you are presented with is:

[full name of data file] + [Default myView name set in your options] + [.mlv]

On re-opening Analyse, if a .mlv file matching this naming convention is found in the same directory as your .qes or .qew, Analyse will automatically load that definition into myView mode.

 

What are the benefits of storing in a .mlv file?

  • The .mlv file sits externally to the .qes or .qew which means it is easily shareable between two colleagues who have the same data file.
  • It's an xml definition which can be opened in a text editor and edited. Once you are au fait with function of the handful of tags used you can adapt or create .mlv files from scratch or do large scale updates using find and replace, or even macros.
  • The definitions work on question shortcut, so even if two data files are different, an existing .mlv file can be used to hide any matching shortcut names between the original data file and a new one.
  • The definition lists what is hidden, so any new variables and responses are automatically shown.  

 

How do I suppress or re-organise questions and responses?

Questions are generally dealt with by right-clicking in the question tree in myView mode.

  • A: This option will remove from myView the questions you have selected
  • B: This option will remove from myView any questions in your selection which have a base of 0
  • C: This option will remove from the myView any questions in the whole questionnaire which have a base of 0
  • D: This option inserts a new chapter and prompts you to give it a name
  • E: These options move your selection of questions up and down the question tree or indent / un-indent.

If you have removed questions but you want to recover them to your myView then simply select: 'Recover removed questions'. You will be presented with a list of previously suppressed questions as shown below. Here you can select one or more questions to recover.

Responses are generally dealt with by first sending your question to the rows, columns or edges of a tab definition.

In the screenshot above you will see I have made some amendments to the top question. I have:

  • Added a grouping for Top 2
  • Added a grouping for Bottom 2
  • Added a calculated response for Top - Bottom
  • Changed the response caption of the third response
  • Changed the caption of the first question
  • Reordered some of the options

Here it's useful to remember that such adjustments can be copied from one question to several others by using the Copy / Paste presentation functionality.

Once you have made the modifications to the questions, you can select them > right-click > 'Set as myView default'. Note the changes to these variables in the distribution window:

The one thing that hasn't changed is the is the question name in the tree. It isn't supposed to, you will notice the change to the question caption only when you send it back to the rows, columns or edges of a tab definition, it's caption will read: 'Caption change' as you saw above.

If you have made changes to the responses but you want to reset them, select the question(s) in the question tree > right-click > Reset responses. It's useful to note here that the undo / redo buttons in the top tool-bar will undo a reset in case it's necessary. 

 

Is there anything else that could come in useful?

Well, perhaps. 

If you have moved a loop into the tab definition and, for example, deselected some codes then, right-click > 'Set as myView default' will prompt you with a follow up option to remove the developed questions that relate to these codes (see below). This can save some time in cleaning a questionnaire with many loops.

Lastly, if you're like me and enjoy a good keyboard shortcut then take a look below:

Ctrl+Alt+O - Open a myView (.mlv) file
Ctrl+Alt+N - New myView (.mlv) file

 

 

 

Have more questions? Submit a request

Comments