Scroll

Updating Custom ADXs to 5.5 (V3)

Updating Custom ADXs to 5.5 (V3)

Follow

Non-functional changes:

To update your custom ADC to be compatible with the newer versions of Design, the first thing you need need to change is the referencing to the newer version of the ADXSchema. This is found in the config.xml

This is referenced on the control block for ADCs and page block for ADPs

For ADCs:

5.5.

xmlns="http://www.askia.com/2.2.0/ADCSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.askia.com/2.2.0/ADCSchema https://raw.githubusercontent.com/AskiaADX/ADXSchema/2.2.0/ADCSchema.xsd"
version="2.2.0"
askiaCompat="5.5.2"

 

For ADPs:

5.5.

xmlns="http://www.askia.com/2.2.0/ADPSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.askia.com/2.2.0/ADPSchema https://raw.githubusercontent.com/AskiaADX/ADXSchema/2.2.0/ADPSchema.xsd"
version="2.2.0"
askiaCompat="5.5.2"

 

Functional Changes:

There are 2 new constraints that have been added to the config file.

 AdxStudio103Constraints.png

These are:

  • manageLoopDepthinteger (attribute of the output) (N) Zero (by default) if the output doesn’t manage the loop and an integer if the output manage the loop (1 if the output manage one level loop, 2 for 2 nested level loops etc....)
  • requireLoopDepthinteger (constraint on questions of the info) (N) Zero (by default) if the adc doesn't need a parent loop, 1 if the adc needs a parent loop,2 if the adc needs 2 nested level loop, etc.

 

MaxVisibleIterations

http://designhelp.askia.com/askiascript2_question_type$MaxVisibleIterations

 

AvailableAnswers

http://designhelp.askia.com/askiascript2_question_type$AvailableAnswers

 

Have more questions? Submit a request

Comments