Scroll

DOC: Compatibility checks when updating a survey on AskiaField

Follow
Summary This article explains the messages you may have during a survey update
Applies to askiafield
Written for field managers
Keywords Survey update; qex ; askiavoice ; Web; Working Copy ; Warnings; errors ; critical ; 5.3.3.32

Documentation Note: add in the tasks documentation

While updating a survey on the Supervisor, you may encountered some messages which indicate possible problems.
These messages are classified in 4 levels of warning, from Low to Critical.
All these messages must require your attention, some of them (High and Critical) must be absolutely fixed / checked before update the survey.

Since the Cca 5.3.3.32, the update of a survey which contains critical errors cannot be proceed: the "ignore all warning" check box is deactivated in this specific level of error. 

Level 1 : Low. That's mostly informational messages.

  1. Last Revision Incompatible: It means there is a difference between the revision in survey on Cca and the qex uses for updated the survey.
  2. Survey Is Older Version Will Upgrade: This message appears at the first survey update after a Cca Upgrade (for example from 5.2.X to 5.3.X). When ganging version, there is new fields to apply to the previous survey structure. The Cca will do it but warn you about this.
  3. Charset Routing Used: With 5.3.3, the usage of Charset is no longer necessary and even can lead to corrupted data. You must remove your charset immediately. In the meantime, the routing "Set Charset" is deactivated in Cca and Webprod.

 

Level 2: Medium. These messages indicates problems which can have an impact on the behavior of the survey.

  1. Imported Field Not Numeric: Problem where a imported sample list field is in numeric into the survey but in text into the sample list. It needs to be fixed as the sample list will be untargeted.
  2. Imported Field Not Found: An importation field declared into the survey is missing into the sample list. Field name is indicated. It needs to be fixed as the sample list will be untargeted.
  3. No Screen For Question: A question is set as visible during data collection, but the screen has not been generated. Need to be fixed as there will be no data collected for this question.
  4. No Screen: Indicates that no screens have been generated for the survey. The survey can only works with "Key In" mode.
  5. Imported Field Not Found In Project: Same as "imported field not found" but for Scripts.
  6. Quota Modality Added: One ore modalities for question in quota have been added in this update. The quota definition should be reviewed after the update.

 

Level 3: High. These problems can have a negative effect on data collection or survey behavior.

  1. Quota Question Deleted: A question presents in Quota has been deleted. Question indicated into the error message.
  2. Quota Sub Question Deleted: A question presents in Quota nested tree has been deleted. Question indicated into the error message.
  3. Quota Question Unavailable: question still exists, but ‘available for quota’ is disabled (and the question is still in quota)
  4. Quota Modality Deleted: One or more modalities from question in quota have been deleted. Tqe quota definition should be reviewed after the update.

 

Level 4 : Critical. These errors indicates that the update cannot be made.

  1. Revision History Incompatible. Surveys are completely different: There is a problem with the qex you are using to update your survey. It could be a corrupted qex or a qex from another survey. 
  2. Revision History Older Version: indicates that you are trying to update a survey with an older version than the actual one. 
  3. No Shortcut: Indicates that there is no shortcut on the questionnaire tree.
  4. Shortcut Already Used: Indicates duplicates into shortcuts names.
  5. Loop Without Question: Indicates there is no sub question to a loop.
  6. No Visible Question: Indicates that there is no visible question for the whole survey. 
  7. Update Source Is Old Version Please Upgrade Update Source: Indicates that you are trying to update a survey running with a specific version of Field/design (for example 5.3.X) with a qex made with a previous (and incompatible) version (5.2.x for example).
  8. Question Changed Type: A question has changed of type and will generate data loss. Update must be cancelled. 
  9. Incompatible Level: A loop question has been set a normal question, or a normal question has been set as a loop. Risk of data loss. Update must be cancelled.
Have more questions? Submit a request

Comments