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Introduction 

Format 
This course comprises seven flexible modular sessions, which permit different 
learning pathways through the training course. It is primarily intended for research 
technicians or CAI (computer-assisted interviewing) scriptwriters who will be 
creating using askiatools to perform a number of maintenance and housekeeping 
tasks on data files such as importing, exporting and editing of data.   

A further, optional module, 410 (in a separate document) covers how to edit data 
in askiatools, using askiascript commands. It requires knowledge of both script 
and tools.  

Each session is intended to last no more than an hour, though it may take longer, 
if additional time is required to complete the practical work. 

Each session follows the same format: 

1. Introduction (by tutor) 2-3 minutes 

2. Tutorial and demonstration 15-20 minutes 

3. Summary (by tutor)  2 minutes 

4. Practical exercises  variable 

5. Recap, feedback and questions 

Pre-requisites 
This course assumes a working knowledge of askiadesign and ideally askiaalyse 
too. The knowledge required is covered respectively by these Askia training 
courses: 

Course 100 Askia Design 

Course 200 Askia Analysis 

Module topics 
Session 401 Importing a questionnaire 

Session 402 Importing data 
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Session 403 Exporting data 

Session 404  Survey file maintenance 

Session 405  Merging data 

Session 406  Data management 

Session 407 Verifying and coding data 

Further training 
Module 410 Editing data for script users 

Anyone wishing to use Tools to edit data should continue on to Session 410, 
which is provided as a standalone training module. Session 410 also requires 
participants to have completed the script training (Course 150 Askiascript), or be 
familiar with the content of that course.  

Learning pathways 
After Session 401, which shows how to use askiatools, each subsequent session 
operates as a standalone module. Various learning pathways can therefore be 
followed, according to the topics of interest to the participant or group receiving 
the training.  

Preparation 
When preparing for this course, you will need to agree the content you will be 
presenting with your client contact. 

If possible, provide the training materials in advance so your client can prepare 
copies for each participant.  

Course agenda and timetable 
Once you have agreed the timetable or programme with your client contact, 
prepare a course agenda showing the start and end times of each session, as 
well as any breaks. 

You should add these timings to the introductory PowerPoint, as well as providing 
it by email or on paper.  

While updating the PowerPoint, modify the title page of the slides to show your 
name and, if possible, the client company’s logo. 

Prepare a one-sheet hand-out for the participants that give them the course 
timings – or email this to them. It is a good idea to have some printed copies. You 
may also have other specific items that you wish to add to this sheet or provide as 
separate sheets – e.g. guidance on their company-specific example project (see 
below) to be used in the exercises, info on how to access the system, and so on. 



Introduction 

7 

Example files 
This course uses a series of example files which are organised into individual 
folders by session, each folder containing the files that are used during that 
session. Within each session folder, you will find a sub-folder containing the files 
to be used in the practical exercises for that session. 

Working with a client-provided questionnaire 

You may be able to work with examples provided by your client. If you plan to do 
this, make sure you receive all of the files (QES, QEX and any other data) in 
advance, so that you can check the files contain examples of all you wish to 
cover. 

Generally, we recommend that you use clients’ files to set up additional exercises 
after the set exercises in this coursebook have been done. Alternatively, if the 
client example contains all the constructs required by the exercise, you can use 
them to substitute for all or part of a set exercise.  

There is no harm in repetition with different examples during a period of training – 
more practice is a good thing, if time permits.  

At the start of the training 

Setting up the room 
Arrive early. Ensure you arrive to give the training in plenty of time, so that you 
have time to set up the room as you would like it. Make it as tidy as possible – it is 
distracting to be learning in a room full of clutter. 

Arrange the seating. Arrange all of the seats so that your group have a clear 
view of the screen and also that you have a clear view of them too – so you have 
facial contact with each of them. Set out enough seats for the group, and put 
away, or move to the back or against the wall, seats you don’t want to be used, so 
it is obvious where you want everyone to sit. 

Flipchart or whiteboard. Ideally, make sure you have a flipchart or whiteboard 
that you can also write up important messages or notes, and the right kind of 
pens (indelible pens for paper; dry-wipe pens for the whiteboard). 

Heat. Make sure the room is warm, but not too warm, and that your group will be 
comfortable.  

Noise. Ensure the door can be closed, so that the group will not be distracted by 
external noise, and also that you won’t be distracting others in the office with your 
training session.  

Light. Adjust the lighting – ensure the screen is bright and visible but not 
dazzled from overhead lights or daylight. Don’t over-dim the room: you also need 
to be visible to the group and you need to be able to see them. 

Course materials. Set out the coursebooks for everyone – and if possible, 
provide them with an Askia pen to use too (or at least, pens from the stationery 
cupboard). Also lay out the course timetable/agenda you have created, or any 



Course 400: Askia Tools Introductory Training • Coursebook with Tutor’s Notes 

8 

other supplementary sheets you have prepared (e.g. on the company-specific 
example project). 

Demo screen and system access. Ensure you know how to work the data 
projector or large screen, that you have access to the system, to the Askia 
software and to the directories containing the training files. After any testing, close 
any apps so you are starting from a ‘cold start’ in your training session.  

PowerPoint. Finally, set the display screen to show the first slide of the course 
PowerPoint set – in full screen mode – so that this is on the screen when 
participants enter for their training.  

Introductory presentation 
Before you start the main training you should: 

• Do introductions of everyone in the group. If time permits, also: 

o Ask each to say what they do 

o Ask each what experience they have in (a) Askia and (b) analysis 
and reporting of market research surveys 

o Ask each to say what they hope to get out of the course 

• Explain the structure of the course – use the first three slides in the 
PowerPoint presentation Course100.ppt. 

• Explain the timings: start times and end times – and when break times will 
occur 

• Explain the materials and resources they will be using: 

o A participant’s coursebook each 

o Access to AskiaDesign 

o Access to the training files 

• If necessary, explain where they will be able to find the files 

• Check that everyone has the materials and resources they need  

• Ask if there are any questions 

• Continue on to Session 401 

Checklists 
This check-list summarises the points described above. Please refer to the more 
detailed descriptions above, for more information. 

During preparation 
¨ Discuss course timings and participants with client and agree schedule 

¨ Update agenda and timings in training course PowerPoint 
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¨ Discuss the example projects with client (you can forward the Word files) and 
review whether additional time should be allowed after the course to work on 
a “real” project.  

¨ Obtain the example project and work through which questions and examples 
will be used in each exercise (see content checklist, above) 

¨ If necessary, where no QEX file exists, import the survey and/or program 
those parts needed for the exercises to work. 

¨ Agree who will print and bind the coursebooks for participants (double-sided 
and bound or in a folder is the preferred presentation) 

¨ Ensure that there are printed copies of the Mobile Internet survey, for use by 
participants during the exercises. 

¨ If you are covering askiaword, ensure that participants will have access to the 
askiaword version of the Mobile Internet survey, with the questions and 
responses already marked up, so that they can open it quickly in Word. 

¨ Prepare and print any supplementary notes – agenda, example project info, 
etc. 

¨ Sort out access to the system, server etc at the client company – will you be 
using their PC or yours? 

¨ Establish who will be able to update the IE settings on participant’s PCs to 
access askiavista.  

¨ Check the training room will have a large screen or projector you can use; 
Internet access for you to use; whiteboard or flipchart and pens 

¨ Check there will be one PC for each participant or each pair of participants 

¨ If you are not familiar with the system configuration and how Askia is 
deployed, check with the Askia team member responsible for the set-up, or 
with your client. Verify, in particular, where/how askiavista is deployed, and if 
projects are stored in SQL.   

¨ Check any other arrangements with your client contact immediately before 
your visit – explain that you would like to have access to the room at least 30 
minutes before your first session begins, in order to get it ready.   

Using an alternative project for participant exercises 
If the students are going to be using an alternative to the Mobile Internet survey 
for the exercises (e.g. the client’s own project), it should include at least the 
following items: 

¨ Two single-coded questions. 

¨ Two multi-coded questions, preferably with at least one including an other 
(specify) type response. 

¨ An open text question. 

¨ An open numeric question. 

¨ A grid. 
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¨ Chapters (if not present in study provided, you can add these in as 
appropriate). 

¨ Demographic questions. 

¨ A structure where respondents might skip at least one question, depending on 
earlier answer/s given. 

¨ Also ensure that: 

¨ you have a version of this study in Microsoft Word format; 

¨ you have marked it up in askiaword, leaving a few questions for the 
participants to mark up for themselves; 

¨ participants will have access to an electronic copy of the marked-up file, so 
that they can open it in Word; 

¨ you have printed copies to give to the students for use during the exercises. 

On the day 
¨ Arrive early 

¨ Arrange the seating and tidy away unwanted seats, clutter etc – make the 
room as tidy as possible 

¨ Adjust the lighting and temperature as appropriate 

¨ Check for noise or other distractions; check you will be able to keep the door 
closed 

¨ Set out coursebooks, agendas and pens for all participants 

¨ Check you have access to the software, the Internet, the example projects 
you need and any passwords required 

¨ Check you have the latest version of askia installed on your PC and on the 
participants’ PCs (see Quick installation, below) 

¨ Check whiteboard or flipchart – and that you have the right pens for each 

¨ Ensure you have a glass or bottle of water to hand 

¨ Ensure you know how to reach your client contact from the training room, in 
case of any problem 

¨ Check PowerPoint slides load and have been edited for this client (and not for 
another client!) 

¨ Finally, have PowerPoint open in presentation mode. This should be open, 
showing the welcome screen, when participants arrive  

Software update, if required 
The best way to ensure you have the latest Askia version of software, including 
the latest templates is to download and install the latest version. This can be 
found at https://dev.askia.com/projects/support/files. When installing the new 
version, make sure you uninstall the previous version of AskiaSuite (through 
control panel) before performing the installation. 
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Session 401 Importing a questionnaire 

Outline 

Topics presented 
In this session, we will introduce you to: 

• Open a QES file 

• Create a QES by importing from a database 

• Create a QES by importing from a file 

• Transform imported questions into loops and multi-coded questions 

• Record and play back macros 

Learning outcomes 
At the end of this session you will understand: 

• Create questionnaires or data structures in Askia by importing them from 
other software tools 

• Navigate and understand the working environment presented within 
AskiaTools 

• Optimise an imported QES for use by Askia 

• Automate questionnaire restructuring to save time on repetitive projects 
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Tutorial 

Introduction to askiatools 

Starting askiatools 
To start askiatools, double-click the icon on your desktop. Alternatively, you can 
open the start menu, click all programs, open the askia program group, and click 
AskiaTools. 

à Start askiatools, and open a QES file (e.g. example_A_merge_interviews_1.qes); 
demonstrate that many commands appear only when you have a QES open. 

à Show the available commands with and without a QES file open (edit, merge, tools 
menus appear). 

à Show (and explain) how a QES is presented in tools (questionnaire tree structure). 

à Explain the commands open… and open inverted survey. 

o You need to use the appropriate open command for the type of survey you are 
opening. 

o If the survey is inverted, the data isn’t contained in the QES, but in a .dat 
subdirectory. 

o If you open a non-inverted survey with this command (or vice versa), tools will let 
you, but it won’t detect any data. No harm will be done, but to work with the data, 
you need to select the right command. 

à Mention open askiafield task – you would use a task when your data is over 2GB in 
size. It can’t go into QES in this situation. 

Importing from delimited ASCII 

About importing 

à Explain that Askia recommends importing from a more structured format, like triple-S, 
wherever possible. However, we will look at ASCII import first, because there are 
various issues to consider when doing this type of import. 

Preparing a file prior to import 

à Explain that this import type always creates a new QES file. 
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à First, open and show the data file example_tab_delimited_import.txt in Excel. 

à Talk through the different field types. 

à Explain that we do not need a unique ID field for this type of import. 

à Explain that it is best practice to fix any issues in the source file before importing it. 

à Explain that, during the import, askiatools looks at all of the rows of the file, to 
analyse the structure and determine the data types.  

à Explain that you should look for the following Issues: 

o Check that you do not have your delimiter (e.g. commas) in text fields. If you do, 
you could choose a different delimiter, or do a replace to remove the delimiter 
from the data. 

o If you have open-ended data, it is a good idea to put in a dummy row at the start, 
with values in the open-ends. Otherwise, if there happens to be no data in any of 
the questions, askiatools will not recognize the questions as being open-ends. 

n Notes for participants 

Before you import a questionnaire, it is best practice to check the file contents, 
and clean up any issues. This makes for a much cleaner import. During the 
import, askiatools examines all of the rows of the file, to analyse the structure and 
determine the data types. However, you should open your file in Excel™ or a text 
editor, to check the following issues: 

• Check that you do not have your file delimiter (e.g. commas, if you are 
importing a comma-separated file) in any open text data. If you do, you 
should do one of the following: 

o remove them systematically from the file; 

o replace them with a different character throughout the file; 

o use a different delimiter character (e.g. a tab). You will need to 
check that this character is not present in the open text data. 

• If you have any open text questions, it is a good idea to put in a dummy 
row at the start of the file, with values in the open text questions, so that 
askiatools will recognise them as open text. Otherwise, if there is no data 
in this question, askiatools will not recognise this question as open text. 

Performing the import 

à Now do the import: 

o Use the command File -> Import -> Delimited ASCII… 

o For the Ascii file, select the file example_tab_delimited_import.txt. 
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o In Askia file, specify a new file (call it Delimited ASCII import example). 

o Talk through the other options (max number of responses, etc.). 

o Then, run the import. 

n Notes for participants 

Note: Askia recommends that you import from a more structured format, such as 
triple-S wherever possible, because this will import more information, such as 
multi-coded questions. 

When you import from delimited ASCII, you will be creating a new QES file to hold 
the questionnaire. Your ASCII file should have a separate row for each record, 
and variables should be separated by a special character (tab, semicolon, colon 
or comma). Note that you do not need a unique ID field for this type of import. 
When you import from ASCII, askiatools does not import any response labels in 
coded questions; you will need to add these to your QES in askiadesign, after the 
import. 

To import a questionnaire from a delimited ASCII file: 

1. In the file menu, select import, then delimited ASCII… 
2. Click … next to ASCII file, and select the file you want to import. 

3. Click … next to Askia file, and select a location and filename for the QES file 
you want to create. 

4. Set the options as follows: 
Option Description 

Max number of 
responses 

If a variable has this number of unique responses or 
fewer, it will be considered a closed question; if it 
has more responses than this, it will be considered 
an open text question. 

For example, if you enter 20 here, then any 
questions with 20 or fewer different responses will be 
treated as closed questions. 

Max number of discrete 
values 

 

If a variable has this number of unique numeric 
responses or fewer, it will be considered a closed 
question; if it has more responses than this, it will be 
considered an open numeric question. 

For example, if you enter 10 here, then any 
questions with more than 10 different numeric 
responses will be considered to be open numeric. 

Question separator Select the character that your ASCII file uses to 
separate the variables (tab, semicolon, colon or 
comma). 

Multiple response 
separator 

The character that will be used to separate 
responses in multiple-response questions (comma, 
colon, semicolon or tab). Select the character that is 
used in your ASCII file. 

Question captions on the If the first row of your ASCII file contains question 
captions, you should select this option. Otherwise, 
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Option Description 

first row ensure this option is not selected. This ensures that 
askiatools interprets the first row correctly. 

 

5. Click OK. Askiatools imports the file and creates the new QES file. 

Checking the import 
à Show the questionnaire’s structure in askiatools. Switch between the original file (in 

Excel) and askiatools to compare. 

o Explain why it has that structure (why askiatools chose certain data types - e.g. 
Q3 is imported as a scaled response question, others as closed questions). 

o Point out that the Q4 has not been imported as a multi, so we will need to 
recreate them; this will be covered later in the session. 

o Go back and edit the data file, adding dummy rows, so that there are more than 
10 discrete values for Q3. Perform the import again. Show that the question is 
now imported as a numeric and not as a coded question. 

o Now open the QES in askiadesign. 

o Show that this import method doesn’t import labels. You might want to add labels 
to coded questions afterwards, or do a replace in Excel before the import. 

o Explain that you can’t just change the variable type in askiadesign, because this 
changes the data. But you could create a new variable based on the imported 
one, in askiadesign. 

à Explain that the other formats (e.g. triple-S) are more powerful, because they import 
more information, such as multi-coded questions. 

n Notes for participants 

Once the import is complete, you will see the new QES structure in askiatools. 
You should reviews the structure to check that the questions have been imported 
as you would expect. 

Depending on the format and contents of your file, there may be certain aspects 
of your questionnaire that askiatools cannot detect when it performs the import. 
You can remedy this after the import, using the utilities in askiatools, and by 
editing the new QES file in askiadesign. In some cases, you may need to repeat 
the import after adding some dummy rows to the file, in order to ensure that the 
questions are interpreted and imported as the correct types. 

Note: By default, when you import an SPSS .sav file, all closed questions are 
imported as scaled responses. You should review them in askiadesign, and 
change the scaled response property if you want them to be standard closed 
questions. You can change this default behaviour by editing a registry setting on 
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your computer. For details, refer to the following Knowledge Base article: 
https://support.askia.com/hc/en-us/articles/203206412-How-to-import-a-
SAV-file-without-scaled-responses-for-closed-questions- 
If any multi-coded questions have been imported as single-coded, you can 
remedy this later in askiatools by using the transform into multiple utility. See 
Transform into Multiple on page 23 for details. 

If any open numeric questions have been imported as closed questions, you will 
need to re-do the import after adding some dummy rows to the start of the file, to 
ensure that more than the appropriate number of discrete values (specified during 
the import, in the option max number of discrete values) are present in the 
data. This could be as simple as adding rows, each with a different values from 1 
to 11 in the variable in question. 

Since askiatools does not create response labels in coded questions when 
importing from ASCII, you will need to open the QES in askiadesign and add the 
labels there. 

Warning: If any of your variables are imported as the wrong type, you should not simply 
change the type in askiadesign, because this will affect the data. Instead, you can create 
a new variable based on the imported one. 

 

Importing from database ADO or Excel™ file 
How to import a questionnaire from an ADO database. 

à Explain that this method allows you to import from an ADO database, or an Excel™ 
file. The process is the same for either method. You need to have ADO running on 
your computer to import ADO, so we will import from Excel to demonstrate this. 

à Use the command File -> Import -> Database (ADO). 

à In ADO connection string, select the file example_excel_import.xlsx. 

à In table or query, select the file worksheet Sheet1$S. 

à In Askia file, specify a new file (call it Excel import example). 

à Then, run the import. 

à Explain that, as with ASCII, askiatools will need to make assumptions, based on what 
it finds in the file. 

à Explain that if the file is greater than 2GB in size, you will need to import it in inverted 
format (select the option into inverted data format). 

à Explain that as with delimited text, this is not the best format to export, as you will 
need to do more after-import tidying up. 
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à Show the questionnaire’s structure in askiatools. Switch between the original file (in 
Excel) and askiatools to compare. 

n Notes for participants 

When you import from a database ADO or Excel™ file, you will be creating a new 
QES file to hold the questionnaire. The procedure is very similar for importing 
from an Excel™ file, so we will cover both methods here. 

Note: Askia recommends that you import from a more structured format, such as 
triple-S wherever possible, because this will import more information, such as 
multi-coded questions. 

 

To import a questionnaire from a database ADO or Excel™ file: 

1. In the file menu, select import, then database (ADO)… 
2. In ADO connection string, type the connection string for the database you 

want to import. Note that you need to have ADO (ActiveX Data Objects) 
running on your computer to import using an ADO connection string.  
Alternatively: 

• to import from an Access™ MDB or ACCDB file, click … and select 
the file you want to import; 

• to import from an Excel™ XLS or XLSX file, click … and select the 
file you want to import. 

3. In table or query, select  

• the database table you want to import (if importing from a database); 

• the Excel™ worksheet to import (if importing from Excel™). 

4. Click … next to Askia file, and select a location and filename for the QES file 
you want to create. 

5. If the file is greater than 2GB in size, you must select into inverted data 
format. 

6. Set the options as described below: 
Option Description 

Into inverted data format Select this if the file you are importing is greater 
than 2GB in size. Otherwise, ensure this is not 
selected. 

Max number of responses If a variable has this number of unique responses 
or fewer, it will be considered a closed question; if 
it has more responses than this, it will be 
considered an open text question. 

For example, if you enter 20 here, then any 
questions with more than 20 different responses 
will be considered to be closed questions. 

Max number of discrete 
values 

 

If a variable has this number of unique numeric 
responses or fewer, it will be considered a closed 
question; if it has more responses than this, it will 
be considered an open numeric question. 
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Option Description 

For example, if you enter 10 here, then any 
questions with more than 10 different numeric 
responses will be considered to be open numeric. 

 

7. Click OK. Askiatools imports the file or database and creates the new QES 
file. 

 

After importing, you should carry out a check of the questionnaire structure, as 
described in Checking the import on page 15.  

Importing from triple-S 
How to import a questionnaire from triple-S. 

à Briefly explain that triple-s is an industry standard for survey data and metadata 
interchange used by many different software packages. It contains questions and 
their associated data but does not contain any questionnaire routing. It is a good 
method of transferring surveys and survey data from one software platform to 
another. 

à Explain that Askia recommends importing from triple-S files where possible, because 
you end up with a well-structured QES. For example, triple-S supports multi-coded 
data, while most other formats don’t. 

à Discuss briefly the difference between triple-S (classic) and triple-S (XML). Explain 
that the method for importing them is the same. 

à Explain that you need two triple-S files:  

o a description file and  

o a data file (flat ASCII). 

à Explain that during the import, askiatools will assume that the data file will have same 
prefix as the description file. You should always check before beginning the import, 
and correct this if the file prefixes differ. 

à Perform a triple-S (classic) import, as follows: 

o Use the command File -> Import -> Triple-S -> Classic. 

o Explain that the source file you select is the triple-S description file. In Triple-S 
source file, select the file triple-S for import.sss. 

o In Askia target file, specify a new file (call it triple-S classic import example). 
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o Show the questionnaire in askiatools, then open it and show it in askiadesign. 
Point out that the multis have been imported, so there is no need to convert 
them, and the labels have also been imported, so there is no need to create 
them. 

n Notes for participants 

Triple-S is an industry standard for survey data and metadata exchange, used by 
many different software packages. It is therefore an excellent means of importing 
a questionnaire into QES format. 

Triple-S data contains questions, and their associated data, but does not include 
questionnaire routing. Because question types are defined within triple-S, and 
triple-S supports multi-coded data, it means there is less work to do after the 
import: 

• multi-coded questions will be defined properly; 

• responses to closed questions (single and multi) will have their labels 
intact. 

When you import from a triple-S file, you will be creating a new QES file to hold 
the questionnaire. 

There are two versions of triple-S, classic and XML. The method for importing 
them is the same. You will need two triple-S files: 

• a description file and  

• a data file.  

Note: askiatools assumes that both of your files have the same prefix. If they do 
not, you should rename them accordingly, or else your import will not complete. 

 

To import a questionnaire from a triple-S file: 

1. In the file menu, select import, then triple-S, then Classic…, or XML…, as 
appropriate to the files you are importing. 

2. Click … next to triple-S source file, then select the triple-S description file. 

3. Click … next to Askia target file, and select a location and filename for the 
QES file you want to create. 

4. If the file is greater than 2GB in size, you must select into inverted data 
format. 

5. Click OK. Askiatools imports the file and creates the new QES file. 

Importing from SPSS Dimensions 
How to import a questionnaire from SPSS Dimensions. 

à Explain that this works only if the user has the Dimensions engine on their PC. If you 
use Dimensions, this should the format you should use. 

à Explain that this is a tidy import that supports loops.  
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à The two most common formats are MDD (with corresponding DDF file) and PKD. We 
will look at MDD. 

à Just talk through the options available; there is no need to do the import here. 
However, if you want to do so, and you have Dimensions installed on your demo 
machine, use the file example_dimensions_import.mdd, 

o Metadata is located in the MDD file; 

o The Case data is in the DDF file. 

o Show how to define the connection string, clicking … and using the data link 
properties dialog. 

§ Just cover the following options in this dialog (all on the connection tab): 

- Metadata location 

- Case data type (Data Collection Data File (read-write) 

- Case data location (if not automatically detected) 

- Test connection 

o Explain the following options in the import dimensions dialog: 

§ Explain that if the Dimensions file was created using an older version (prior 
to 5.6), or you are aware the Respondent ID Field is not “RespondentSerial”, 
then specify it in Respondent ID. 

§ Askia target file 

§ Numeric DK values: If you are aware that a standard/ fixed numeric value 
for “DK” (Don’t know) was used for ALL questions in the Dimensions file, 
specify it here, and the caption in system DK caption.  

§ Group all DKs in system modality: select this if you wish to group all of 
your “DK” codes/ values into one answer/ category in the resulting QES. 

§ Explain that if the resulting QES file will be greater than 2GB in size (the limit 
for Access databases), you will need to import it in inverted format (select 
the option into inverted data format). 

§ Develop levels when…:  

- “0” : all levels/ loops will be developed. 

- “1”: none of the levels/ loops will be developed. 
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-  “2”: only grids will be developed. 

n Notes for participants 

Importing from SPSS Dimensions format results in a tidy QES file, with loops. The 
two most common formats are MDD (with corresponding DDF file) and PKD. In 
the case of MDD, the Metadata is located in the MDD file and the Case data is in 
the DDF file. 

Note: you can import from SPSS Dimensions if you have the Dimensions engine 
installed on your PC.  

To import a questionnaire from SPSS Dimensions: 

1. In the file menu, select import, then SPSS (dimensions)…. 

2. Next to Dimensions connection string, click …. The data link properties 
dialog appears. 

3. Leave the metadata type set as the default setting (data collection metadata 
document). 

4.  Next to metadata location, click browse…, and select the .MDD file you 
want to use. 

5. In case data type, select data collection data file (read-write). 
6. If the case data location file has not been automatically found, click 

browse… and select it. 

7. Click test connection, to ensure that askiatools is able to successfully 
connect to the database. You should see a message confirming that the test 
connection succeeded; click OK to dismiss this message. 

8. Click OK to confirm your settings and close the data link properties dialog. 

9. If the Dimensions data file was created using an older version (earlier than 
5.6), or you are aware that the Respondent ID field is something other than 
“RespondentSerial”, specify the field name in respondent ID. 

10. Next to Askia target file, click … and specify the location and file name for 
the QES file you want to create. 

11. Set the other options as follows: 
Option Description 

Numeric DK values If you are aware that a standard/ fixed numeric 
value for “DK” (Don’t know) was used for all 
questions in the Dimensions file, specify the value 
here (and see system DK caption below).  

System DK caption If you are aware that a standard/ fixed numeric 
value for “DK” (Don’t know) was used for all 
questions in the Dimensions file, specify the 
caption you wish to use for them here (and see 
numeric DK values above).  

Group all DKs in system 
modality 

Select this option if you wish to group all of your 
“DK” codes/values into one answer/category in 
the resulting QES file. 

Into inverted data format If the resulting QES file will exceed the size limit 
for an Access database – 2GB – select the option 
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Option Description 

to import data into inverted format. 

Develop levels when depth 
<: 

If you only wish to develop levels (loops) in the 
resulting imported QES file when their depth is 
below a specific amount, specify as follows: 

• If you leave this value set to 0, all 
levels/loops will be developed. 

• A value of “1” will ensure that none of the 
levels/ loops will be developed. 

• A value of “2” will ensure that only grids 
will be developed. 

 

12. Click OK to perform the import. Once the import is finished, the structure (tree 
view) of the resulting QES file is displayed in askiatools. 

Importing from SPSS .sav 
How to import a questionnaire from SPSS Dimensions. 

à Explain that this import method has no options; it just does the import. 

à Explain that tt doesn’t import multis or loops, so you will need to fix these after the 
import. 

à Perform the import: 

o Use the command File -> Import -> SPSS (.sav). 

o Select the file example_import_from_sav.sav. 

o For the output file, name your file sav import example. 

à Show the resulting questionnaire in askiatools, then open it and show it in 
askiadesign. 

à Show that multis come in as series of singles - e.g. “reasons” questions. 

n Notes for participants 

Importing from SPSS .sav doesn’t import multi-coded questions (they are 
imported as a string of single-coded questions) or loops, so you will need to fix 
these after the import (see After the import on page 23). 

To import a questionnaire from an SPSS SAV file: 

1. In the file menu, select import, then SPSS (.sav)…. 

2. Select the .sav file you want to import, and click open. 

3. Specify a location and file name for your QES file, and click save. Askiatools 
imports the file and creates the new QES file. 
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After the import 
Explain: Once your import is done, you need to perform some “tidying up”, to 
ensure the questionnaire is well structured. 

n Notes for participants 

Once your import is done, you will probably need to perform some “tidying up”, to 
ensure the questionnaire is well structured, especially if you did not use one of the 
more structured formats like triple-S or Dimensions. 

Transform into Multiple 

à Explain that if you imported from a format that doesn’t support multiples, you can 
remedy this. 

à Explain that transform into multiple creates new multi-coded variables, based on 
selected questions in your imported QES. You need to identify the questions that will 
be transformed. 

à Open the QES file example transform.qes. 

à Explain that you need to select Tools -> Transform into multiple (yes/no) or 
Transform into multiple (no/yes), depending on the order any yes/no responses 
are in (e.g. if 0 is no, and 1 is yes, you would select no/yes). 

o In this case, we will select Transform into multiple (no/yes). 

à In the dialog, move the REASONS questions (REASONS_1 to REASONS_16) into 
the right-hand box, and click OK. 

à Explain that it creates a new, multi-coded variable, but: 

o leaves the individual (single-coded) variables in the QES; 

o de-selects the “visible in analyse” option for the original variables, so they do not 
appear during data analysis. 

à Open the QES in askiadesign, to show the new multi-coded question. 

n Notes for participants 

If the import format you used does not support multi-coded variables, then you will 
need to remedy this by transforming the resulting single-coded variables into 
multiples. 

Warning: If any of your multi-coded variables were imported as the wrong type, you 
should not simply change their type in askiadesign, because this will affect the data. 
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Instead, you should use the transform into multiple utility in askiatools. 

This utility creates new multi-coded variables, based on the questions you select 
from your imported QES. It leaves the individual (single-coded) variables in the 
QES, but de-selects the visible in analyse property for each, so that they do not 
appear during data analysis. 

To transform variables into multi-coded variables: 

1. In askiatools, open the QES file. 

2. In the tools menu, select as appropriate to your data set: 
Option Description 

transform into multiple 
(yes/no) 

The first code found for each question to be merged 
will be treated as “yes” (or positive). 

This command is appropriate, for example, when ‘1’ 
in the data indicates a positive value and ‘2’ 
indicates a negative. 

transform into multiple 
(no/yes) 

The first code found for each question to be merged 
will be treated as “no” (or negative). 

This command is appropriate, for example, when ‘0’ 
in the data indicates a negative value and ‘1’ 
indicates a positive. 

 

3. In the question selection dialog, move the questions you want to transform to 
the right-hand list. To move a question, click it and then click the right-pointing 
arrow: 
 

 
4. If you change your mind about a question, you can move it out of the right-

hand list, by selecting it and clicking the left-pointing arrow: 
 

 
5. Click OK. 

Transform into Loop 

à Explain that as with multiples, if you imported from a format that doesn’t support 
loops, you can remedy this. 

à Open the QES file example transform.qes. 

à Select Tools -> Transform into loop. 

à In the dialog, move the APPRECIATION questions into the right-hand box. 

à Explain that you are going to deliberately make an error, to demonstrate what 
happens. Move TYPE_1 into the right-hand box too. 
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à Click OK.  

à Explain the warning message, and click No, to cancel the operation. 

à Now repeat the above, but this time don’t make the mistake. 

à Explain that this procedure creates a new loop, but: 

o leaves the individual variables in the QES; 

o de-selects the “visible in analyse” option, so they do not appear during data 
analysis. 

à Open the QES in askiadesign, to show the new loop. 

n Notes for participants 

If you imported a questionnaire from a format that does not support loops, then 
you can remedy this in askiatools. This utility creates a new loop, but leaves the 
original variables in the QES. It de-selects the visible in analyse property for 
each, so they will not appear during data analysis. 

To transform variables into loops: 

1. In askiatools, open the QES file. 

2. In the tools menu, select transform into loop…. 

3. In the question selection dialog, move the questions you want to transform to 
the right-hand list. To move a question, click it and then click the right-pointing 
arrow: 
 

 
4. If you change your mind about a question, you can move it out of the right-

hand list, by selecting it and clicking the left-pointing arrow: 
 

 
5. Click OK. 

Adding chapters 

à Explain that you may want to add chapters to the QES, using askiadesign, before you 
do your analysis. 

à Demonstrate opening the QES in askiadesign, adding a chapter, and putting 
questions into it. 
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n Notes for participants 

After importing your survey, you may want to reorganise the survey in 
askiadesign, for example adding chapters and organising questions into them. 

 

Warning: If any of your variables are imported as the wrong type, you should not simply 
change the type in askiadesign, because this will affect the data. Instead, you can create 
a new variable based on the imported one. 

Using Macros 
Using macros to automate repeated tasks. 

à Explain that if you carry out repeated tasks – for example, receiving new versions of a 
SAV file on a regular basis – then you can save time with the data clean-up 
(transform into a loop, etc.) with macros. 

à Explain: 

o Macros are easy to create. You simply record a set of actions, and can then “play 
it back”. 

o Macros can only be used to record and play back “transform” operations: 
transform into loop and transform into multiple. 

o Macros are saved as XML files. 

o When you run a macro, the actions are applied to questions with the same 
names as the ones you transformed when you recorded the macro. 

à Demonstrate: 

o Open the QES file you macro example transform 1.qes. 

o Start recording, and perform a transform into multiple (no/yes) on the 
REASONS questions (REASONS_1 to REASONS_16). 

o Stop recording, and save the macro file. Show the changes to the questionnaire 
in askia design. 

o Open the QES macro example transform 2.qes. 

o Run the macro you just recorded. Show the changes to macro example 
transform 2 in askia design. 

 



Session 401 Importing a questionnaire 

27 

n Notes for participants 

If you carry out repeated questionnaire clean-up transformations – for example, 
you receive new versions of a SAV file on a regular basis and carry out the same 
transformations each time – you can record these in a macro and then run (or 
“play back”) the macro to save time. 

Macros are easy to create. You simply record a set of actions, and can then play 
back the macro at a later date. You can only record the transform into loop and 
transform into multiple commands; other commands in askiatools are not 
recorded. 

When you run a macro, the commands are applied to questions with the same 
names as the ones you transformed when you recorded the macro. Therefore, 
this feature works very well if you repeat the same activity on similar 
questionnaire files. 

To record a macro: 

1. In askiatools, open the QES file. 

2. In the tools menu, select macro, then record. 

3. Perform the transform into multiple and transform into loop commands 
that you want to record. 

4. If you make a mistake, you can cancel the macro recording, by selecting 
cancel from the macro sub-menu. Your macro is not recorded, and you can 
skip the rest of this procedure. 

5. When you have finished performing transform actions on your QES, in the 
tools menu select macro, then stop.  

6. Specify a location and filename for the macro’s XML file and click save. Your 
macro file is created. 

 

To run a macro: 

1. In askiatools, open the QES file on which you want to run the macro. 

2. In the tools menu, select macro, then run…. 

3. Select the macro file you want to run. 

Recap 
à Provide a one-minute summary of the topics covered and then prepare participants 

for the exercise. 

In this session, we have: 

• Looked at several import methods in askiatools. 

• Tidied up the questions and structure of the QES after doing an import. 

• Recorded and run a macro. 
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Practical exercises 
à Ask the participants to complete these exercises. For the .sav files, either use the 

supplied exercise files for session 401, or a simplified “real” example from the client. 

Exercise 1: Importing an unstructured file 
In this exercise, you will import an SPSS .sav file. Your tutor will tell you which file 
to use. 

Please follow these steps: 

1. Start askiatools. 

2. In the file menu, select import, then SPSS (.sav)…. 

3. Select the .sav file, and click open. 

4. Specify a location and file name for your QES file, and click save. 

5. Examine the QES structure in askiatools. 

Exercise 2: Cleaning up a file, and recording a macro 
In this exercise, you will “clean up” a series of variables in a QES file, and save 
your actions as a macro, so that you can apply it to a future import. 

Please follow these steps: 

1. In askiatools, open the file macro example transform 1.qes. 

2. In the tools menu, select macro, then record. 
 
Note that if you make a mistake while recording your macro, you can cancel 
the recording by selecting cancel from the macro sub-menu. If you do that, 
your macro is not recorded, and you start the macro recording again. 

3. In the tools menu, select transform into multiple (no/yes). 
4. In the question selection dialog, move the REASONS questions 

(REASONS_1, REASONS_2 etc.) into the right-hand list by selecting them 
and clicking the right arrow: 

 
5. Click OK. You will see a new multi-coded question, REASONS, appear in the 

QES structure. 

6. In the tools menu, select macro, then stop. 

7. Enter a name for your macro and click save.  
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Exercise 3: “Playing back” your macro to clean up another 
file 

Finally, you will apply the clean-up operation you just recorded to another file. 

1. Open the file macro example transform 2.qes. 

2. In the tools menu, select macro, then run. 

3. Select the macro file you saved in the previous exercise, and click open. 

4. You will see a new multi-coded question, REASONS, appear in the QES 
structure. 
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Session 402 Importing data 

Outline 

Topics 
In this session, you will learn how to: 

• Import interview data from Askia DAT files 

• Import data from fixed-length ASCII files 

• Import Askia XML interview data from a CAPI interviewing device 

Learning outcomes 
At the end of this session, you will be able to: 

• Populate a questionnaire you have created in Askia with data collected in 
another data collection tool 

• Recover interview data saved in data files, instead of the QES during 
fieldwork 

• Recover interview data manually from a CAPI interviewing device 
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Tutorial 

Importing interviews from a directory 
How to import interview files from a directory. 

à Explain that, during fieldwork, if it is not possible for the data to be saved in the QES 
files – for example, if the QES is open elsewhere – then the data goes into DAT files. 
The CCA records a log warning to indicate this. You may also notice a different 
number of completes in Supervisor, compared to the number of records in the QES. 

à We can import interviews into a QES from a directory containing DAT files. 

à You need to open the QES before doing the import. 

à Explain that there are two options when we import interviews from a directory – 
without duplicates, or all records. 

à Perform a DAT import: 

o Open import_interviews_example.qes. 

o Use the command File -> Import data -> Interviews from directory -> Without 
duplicates to import the interviews from the directory import_interviews 

n Notes for participants 

During fieldwork, sometimes it is not possible for the data to be saved in the QES 
– for example, if the QES file is open in another application. In this situation, the 
data is stored in temporary DAT files, with one file per interview. You can 
determine this has happened in two ways: 

• Askia CCA records a log warning to indicate this has happened; 

• The number of completed interviews shown in Supervisor will be greater 
than the number of records in the QES, because some of the interviews 
will be stored in the external DAT files. 

Askiatools allows you to easily import these interviews into the QES. You can do 
by omitting any duplicate records, or importing them all. 

To import interviews in DAT files: 

1. In askiatools, open the QES file into which you want to import the interviews. 

2. In the file menu, select import data, then interviews from directory, then 
select without duplicates or all…. 

3. Select the directory containing the interviews, and click OK. The interviews 
are imported into the QES. 
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Importing fixed-length ASCII 
Importing fixed-length ASCII data. 

à Explain: 

o If a data map is defined in the QES you have open, you can import data into it. 

o We will cover defining data maps in session 403. 

o You can import data using a simplified or detailed data map. 

à Demonstrate: 

o Open the file import_fixed_length_ASCII.qes. 

o Select File->Import data->Fixed-length ASCII using->Simplified map... 

o Select the file import_fixed_length_ASCII.txt. 

à Explain that if your survey includes nested loops, you will need to import the data in 
delimited ASCII format, not fixed-length. For details of importing nested loops in 
delimited ASCII data, please see the related Knowledge Base article. 

n Notes for participants 

Note that before you import fixed-length ASCII data, you need to define the QES’s 
data map. See Defining the data map on page 38 for details. 

To import data in fixed-length ASCII format: 

1. Open the QES file. 

2. Ensure you have defined the data map; see Defining the data map on page 
38 for details. 

3. In the file menu, select import data, then fixed length ASII using, then 
simplified map…. 

4. Select the data file you want to import, and click OK. 

Importing Askia XML interviews 
Importing Askia XML interview files. 

à Explain: 

o You can import Askia CAPI interview files manually from iOS and Android 
devices; these are in Askia XML format. 

à Demonstrate: 



Course 400: Askia Tools Introductory Training • Coursebook with Tutor’s Notes 

34 

o Perform an Askia XML import: 

§ Use the command File -> Import data -> Askia XML interviews… 

§ Select the file Askia_XML_example.xml. 

De-duplicating data 
How to remove duplicate records after an import. 

à Explain that during an import, you might end up with duplicate records. 

à When you run the de-duplicate operation, it will discard records that have the same 
ID as another record. You need to specify which question to use as the ID. 

à Demonstrate performing a de-duplicate: 

o Use the file de-duplicate example.qes. 

o Select Merge -> Delete duplicates using id… 

o Select Unique_ID as the ID question. 

o Show the resulting message. 

à Explain how the askiatools determines which records are kept in the case of 
duplicated: 

o It keeps complete rather than incomplete records as a priority. 

o If both interviews were completed, it discards the one that was completed more 
quickly. 

o If neither interview was completed, it discards the interview that was interrupted 
at the earlier point in the questionnaire. 

Recap 
à Provide a one-minute summary of the topics covered and then prepare participants 

for the exercise. 

In this session, we have seen how to: 

• Import interviews from DAT files. 

• Import fixed-length ASCII files. 
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• Manually import Askia XML interview files from iOS and Android devices. 

Practical exercise 
à Ask the participants to complete this exercise. For the data files, either use the 

supplied exercise files for session 402, or a simplified “real” example from the client. 

Importing fixed-length data 
In this exercise, you will import data into a new QES file. 

Please follow these steps: 

1. In askiatools, open the file import_fixed_length_ASCII.qes. 

2. In the file menu, select import data, then fixed length ASCII using, then 
simplified map…. 

3. You are asked if you want to define the map: answer yes. 

4. Right-click and select generate. 

5. Click OK to finish defining the data map. 

6. In the file menu, again select import data, then fixed length ASCII using, 
then simplified map…. 

7. Select the data file import_fixed_length_ASCII a.txt and click open. 

8. Note how many records were imported. If askiaanalyse is available on your 
computer, open the QES file there and note how many records are present in 
the file. 

9. Now we will import a second batch of records. In the file menu, select import 
data, then fixed length ASCII using, then simplified map…. 

10. Select the file import_fixed_length_ASCII a.txt and click open. 

11. Note how many records were imported. If askiaanalyse is available on your 
computer, open the QES file there and note how many records are present in 
the file.
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Session 403 Exporting data 

Outline 

Topics 
In this session, we will introduce you to: 

• Export to triple-S,  

• Export to fixed-length ASCII or Delimited ASCII 

• Export to SPSS Dimensions  

• Export to SPSS SAV  

• Export to XML  

• (If required) Export to Card Column Punch (80-column card image) format 

• Export in Askia DAT format to a directory of files 

• Export interviews as a Microsoft Word questionnaire, including the data 

Learning outcomes 
After this session, you will be able to: 

• Export interview data from your QES into any of several file formats 
• Export interviews to Word for data checking 
• Filter the data you export, according to the language used in the data 

file 
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Tutorial 

Defining the data map 
Defining the data map before doing an export. 

à Explain: 

o Explain that a data map tells askiatools where each question begins and ends in 
the data file. 

o You need to define the data map before you export into certain formats; for 
example triple-S and fixed-length ASCII. 

o If you have not defined a data map and you try to export to a format that requires 
it, you will be prompted to define the map. 

à Demonstrate: 

o Open the file export_example.qes. 

o Select File -> Data map definition -> Simplified… 

o Explain that askiatools can automatically create the data map for us. Right-click 
and select generate.  

o Briefly talk through the following columns: (exported, start, length); we will 
come back to these shortly. 

o Right-click and select options. 

o Explain that you would usually accept the default options. Explain the following 
options: 

§ Export ID: if you select this, an ID field will be exported at the start of each 
record, with the width that you specify here. 

§ Binary export for single by default: if this is selected, single-coded 
questions will be exported in binary format (1 if the answer was selected, 0 if 
not). 

- This means that one column will be reserved for each response (if the 
variable has 10 responses, there will be 10 columns). 

- If this is not selected, the width in the data file reserved for the data will 
be determined by the number of digits in the highest response number 



Session 403 Exporting data 

39 

(e.g. if there are 10 responses, the width will be 2 – sufficient to store 
the number 10). 

§ Binary export for multiple by default: is the same, except for multi-coded 
questions. 

§ Export numeric: If you want to export the numeric data, you need to ensure 
this is selected. 

- Describe the default size for numerics. 

§ Export open-ended: If you want to export the open-ended data, you need 
to ensure this is selected.  

- Also describe the default size for open-ended. 

o Click OK to apply the options. 

o Right-click and select generate again, to create a new map with the new 
settings. 

o Review the list of questions in the map, and talk through the start and length 
columns. 

o Check that all of the questions you want to export have a check/tick in the 
exported column. 

o Explain that if a question has been added to the questionnaire since the data 
map was created, you can automatically adjust the map. Right-click the question 
that has been added, and click adjust from here. 

o Talk through some common errors during the export: 

§ The field width on a multi may be too narrow. This can happen when later 
responses are not represented in the data, so insufficient columns are 
allocated to it. 

§ Explain that if you see any errors, adjust the map and re-export your data, if 
you have already exported it. 

o Demonstrate verifying the map (right-click and select verify). Explain that this 
checks for possible overlaps of data (a question whose start position begins 
“inside” another question). This verifies the map, not the data itself (so you may 
still get data-related errors during the export). 

n Notes for participants 

If you want to import or export certain data formats (for example, fixed-length 
ASCII or triple-S), then you need to define a data map. In the case of an export, 
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this tells askiatools where to find or place each variable in the imported or 
exported data file.  

Askiatools provides two ways to define your data map: 

• Simplified definition 

• Detailed definition 

In this course, we will cover simplified data map definition. 

Askiatools can normally create the data map for you, by interpreting the structure 
of the QES. In some situations, you will want to make adjustments to this. The 
following procedure guides you through automatically creating the map, and also 
making adjustments where necessary. 

To define a QES file’s data map: 

1. Open the QES file. 

2. In the file menu, select data map definition, then simplified…. 

3. To have askiatools automatically create the map, right-click and select 
generate. 

4. In the data map generation window, there are several columns, which indicate 
the following about the data map: 
Column Description 

Exported If this is selected, the variable in question will be exported 
during an export operation. 

Start 

 

Defines the column where the variable will “start” in any 
export or import operations. 

Length Defines the “length” of the variable (i.e. the number of 
character-columns used by the variable in the data file). 

Binary If selected, the variable's data will be imported or exported 
in binary format. 

Spacing Indicates any free spaces left between variables in the 
data. 

Responses The number of response items the variable has. 

Max responses The maximum number of responses which could be 
selected in this variable during fieldwork. 

Occurrences The number of times a loop’s sub-question was iterated 
during fieldwork. 

 

5. Usually, you can accept the default options. In this situation, skip ahead to 
step 7. If you want to change some of the settings, right-click and select 
options. The most commonly-used options are described below. Once you 
have set the options to your liking, click OK. 
Option Description 

Export ID If this option is selected, the respondent ID field will 
be exported at the start of each record. In size, 
specify the width of this field. 

Binary export for single by If selected, single-coded closed questions will be 
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Option Description 

default 

 

imported/exported in binary (each column will 
contain 1 if the answer was selected, 0 if not). One 
column will be generated for each response (e.g. if 
the variable has two responses, the length will be 
2). 

Binary export for multiple 
by default 

If selected, multi-coded closed questions will be 
imported/exported in binary (each column will 
contain 1 if the answer was selected, 0 if not). One 
column will be generated for each response (e.g. if 
the variable has two responses, the length will be 
2). 

Numerics: default size Determines the default length used for numeric 
questions when the map is generated. 

Export open-ended If selected, open-ended questions will be exported. 

Opens: default size Determines the default length used for open 
questions when the map is generated. 

 

6. If you made any changes to the options, you will need to re-generate the data 
map. To do so, right-click and select generate. Otherwise, simply proceed to 
step 7. 

7. Check the contents of the data map, and adjust data positions and lengths if 
necessary.  

8. Ensure that all the variables you want to import or export have a check/tick in 
the exported column. 

9. Click OK. 

Note: if a question has been added to the questionnaire since the data map was 
created, you can automatically adjust the map from that point onwards. Right-click 
the question that has been added, and select adjust from here. 

Checking the data map 
You can have askiatools check the data map for possible overlaps of data (where 
a question’s start position falls “inside” another question’s allocated data 
positions). Note that this verifies the structure of the map, not the data itself. To 
do so, when defining the data map, right-click and select verify. Askiatools will 
inform you of any problems in the data map structure. 

Exporting triple-S 
à If not already covered in session 1, briefly explain that triple-s is an industry standard 

for survey data and metadata interchange used by many different software packages. 
It contains questions and their associated data but does not contain any 
questionnaire routing. It is a good method of transferring surveys and survey data 
from one software platform to another. 

à Explain that when you export in triple-S format, you need to define a data map. 
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à Demonstrate: 

o Open the file export_example.qes. 

o If you have not covered defining the data map, do so now. See Defining the data 
map on page 38. 

o By default, all questions are included in the export, but you can export only 
specific questions by selecting a selection of questions. 

o Cover the filtering options (export completes only, interview started after and 
additional filter. The latter allows you to export a subset of the data – e.g. 
respondents who purchase a specific product). 

§ Filter definition is written in askiascript, and is beyond the scope of this 
course. It is covered in depth in the askiascript course, and in the 
askiadesign Assistant. 

§ An example filter is as follows: 
 
Q1 Has(1) 
 
would select only those interviews where response 1 was given at Q1. 

n Notes for participants 

n  

When you export triple-S data, you need to first define a data map. See Defining 
the data map on page 38 for details. 

By default, all questions are included in the export, but you can export specific 
questions by selecting a selection of questions. 

To export data in triple-S format: 

1. In askiatools, open the QES file. 

2. In the file menu, select export, then triple S…. If you have not defined a data 
map, you will be taken to the data map definition screen. See Defining the 
data map on page 38 for details. You will then need to begin this export 
procedure again. 

3. Next to triple-S file, click …, specify a location and filename for the data file 
you want to create, and click save. 

4. Select the triple-S format you want to export to: classic triple-S, or XML 
triple-S 2.0. 

5. Select which data is exported, by setting the following options:  
Option Description 

Export completes only Select this if you don’t want to export 
incomplete interviews. 
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Option Description 

Interview started after 

 

You can select a date here, to export 
only the interviews that began after this 
date. 

Additional filter Here, you can specify a filter, written in 
askiascript, if you want to export only a 
subset of the data. Askiascript is 
beyond the scope of the course; please 
refer to the askiadesign Assistant for 
details. 

 

6. Click OK to begin the export.  

Interviews to directory 
How to export interview DAT files to a directory. 

à Explain that it is possible to export interviews from the QES into separate DAT files. 

à Create a new directory for the interview files. 

à Open the QES export_interviews_to_directory.qes. 

à Export the interviews to the directory you just created. 

n Notes for participants 

You can use askiatools to export interviews to DAT format. 

To export interview data to a directory in DAT format: 

1. In askiatools, open the QES file. 

2. In the file menu, select export, then interviews to directory…. 

3. Select the directory into which you want to export the interview files, and click 
OK. 

Fixed-length ASCII 
How to export interviews to fixed-length ASCII format. 

à Explain that this is a similar process to exporting to triple-S. 

à Perform an export: 

o Open the file export_example.qes. 
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o If you have not covered defining the data map, do so now. See Defining the data 
map on page 38. 

o Select File -> Export -> Fixed length ASCII using -> Simplified map… 

n Notes for participants 

When you export fixed-length ASCII data, you need to first define a data map. 
See Defining the data map on page 38 for details.. 

To export data in fixed-length ASCII format: 

1. In askiatools, open the QES file. 

2. In the file menu, select export, then fixed-length ASCII using, then 
simplified map…. If you have not defined a data map, you will be taken to 
the data map definition screen. See Defining the data map on page 38 for 
details. You will then need to begin this export procedure again. 

3. Specify a location and filename for the data file you want to create, and click 
save. 

Exporting to delimited ASCII 
How to export interviews to delimited ASCII format. 

à Explain that this is a useful format for exporting open-ended interview data. This 
makes it the best export format for exporting data to be coded. 

à Demonstrate an export: 

o Open the file export_example.qes. 

o Select File -> Export -> Delimited ASCI… 

o If you are exporting for coding, you should select all open-ended. 

n Notes for participants 

You can export data to a delimited ASCII file. This is a useful format for exporting 
open-ended interview data. It is therefore a useful format when exporting data to 
be coded. 

To export data in delimited ASCII format: 

1. In askiatools, open the QES file. 

2. In the file menu, select export, then delimited ASCII…. 

3. Next to ASCII file, click …, specify a location and filename for the data file 
you want to create, and click save. 

4. If you are exporting a file of open-ends to be coded, you should select the 
option all open-ended. 
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5. In question separator, specify the character to be used to separate 
questions. 

6. In multiple responses separator, specify the character to be used to 
separate responses in multi-coded questions. 

7. Select which data is exported, by setting the following options:  
Option Description 

Export completes only Select this if you don’t want to export 
incomplete interviews. 

Interview started after 

 

You can select a date here, to export 
only the interviews that began after this 
date. 

Additional filter Here, you can specify a filter, written in 
askiascript, if you want to export only a 
subset of the data. Askiascript is 
beyond the scope of the course; please 
refer to the askiadesign Assistant for 
details. 

 

8. Click OK to begin the export.  

Dimensions and SAV 
Exporting to SPSS Dimensions and SAV formats. 

à Explain that: 

o The procedure is similar to importing these formats. 

o Dimensions exports can only be done in MDD format. 

à Demonstrate a SAV export. 

o Open the file export_example.qes. 

o Select File -> Export -> SPSS sav format… and perform the export. 

n Notes for participants 

Note: you can import from SPSS Dimensions if you have the Dimensions engine 
installed on your PC. 

Note: when exporting to Dimensions, askiatools can only export in MDD format. 

To export to SPSS Dimensions: 

1. In askiatools, open the QES you want to export. 

2. In the file menu, select export, then SPSS Dimensions…. 
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3. Specify a location and filename for the data file you want to create, and click 
save. 

4. The data link properties dialog asks you to confirm your choices of file 
locations, file names and file types. Click OK to begin the export. 

 

To export to SPSS SAV format: 

1. In askiatools, open the QES you want to export. 

2. In the file menu, select export, then SPSS sav format…. 

3. Next to SAV file, click …, specify a location and filename for the data file you 
want to create, and click save. 

4. Select which data is exported, by setting the following options:  
Option Description 

Export completes only Select this if you don’t want to export 
incomplete interviews. 

Interview started after 

 

You can select a date here, to export 
only the interviews that began after this 
date. 

Additional filter Here, you can specify a filter, written in 
askiascript, if you want to export only a 
subset of the data. Askiascript is 
beyond the scope of the course; please 
refer to the askiadesign Assistant for 
details. 

 

5. Click OK to begin the export.  

Exporting the questionnaire in XML format 
à How to export the questionnaire in XML format. 

à Perform an XML export: 

o Open the file export_example.qes. 

o Use the command File -> Export -> XML questionnaire… 

n Notes for participants 

Askiatools allows you to export the questionnaire in XML format. This is especially 
useful if you want to restructure other QES files based on this one. For details, 
see Rebuilding the questionnaire based on the contents of a file on page 66. 

To export to XML format: 

1. In askiatools, open the QES you want to export. 

2. In the file menu, select export, then XML questionnaire…. 
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3. Specify a location and filename for the data file you want to create, and click 
save. 

Card Column Punch 
How to export to card column punch format. 

à Explain that this an archaic format, largely redundant, but is sometimes needed for 
compatibility reasons. You should use other formats wherever possible. 

à Explain that we need to define a detailed data map. We won’t cover that in this 
course, however. 

à This feature is seldom needed, so there is no need to go into detail. However, if you 
want to demonstrate this export: 

o Use the file export_example.qes. 

o Select File -> Data map definition -> Detailed… 

o Set the detailed data map options as appropriate. 

o Right-click and select generate. 

o Select File -> Export -> Fixed length ASCII using -> Detailed map… 

n Notes for participants 

For reasons of compatibility with older third-party software, you may sometimes 
need to export to card column punch format. This is essentially the same as 
exporting to fixed-length ASCII. However, you need set up a detailed data map 
when exporting to this format, which is beyond the scope of this course; please 
see the Askia Field Assistant for details. 

To export data in card column punch format: 

1. In askiatools, open the QES you want to export. 

2. In the file menu, select export, then fixed-length ASCII using, then detailed 
map…. If you have not defined a data map, you will be taken to the data map 
definition screen. Note that defining a detailed data map is beyond the scope 
of this course; please see the Askia Field Assistant for details. 

3. Specify a location and filename for the data file you want to create, and click 
save. 
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Exporting interviews to Word™ 
à Explain that this command exports one questionnaire per record populated with the 

data. The questionnaires are exported in in Rich Text Format, suitable for opening in 
Microsoft Word™. 

à It can be used for data checking, or to follow up a CATI interview with a face-to-face 
interview, where you want the interviewer to have the previous responses. 

à Open the QES example_export_interviews_to_word.qes. 

à Select File -> Export -> Interviews to Word… 

à Specify the RTF filename, and briefly talk through the export options: 

o Create one file per interview will create a separate RTF for each record; 
otherwise, they will be together in one RTF document. 

o Questions allows you to control which caption is exported for questions. 

o By default, all questions are included in the export, but you can export only 
specific questions by selecting a selection of questions. 

o You can filter which records are exported, by selecting export completes only, 
or by setting interview started after (interviews started before this date will be 
omitted from the export).  

n Notes for participants 

You can export questionnaires in Rich Text Format, populated with interview data 
(one questionnaire per record). This is useful for data checking, or to perform 
follow-up face-to-face interviews where you want the interviewer to have the 
respondent’s previous answers. 

This export produces a Rich Text Format file, suitable for opening in Microsoft 
Word™, and other leading word processing programs. 

To export data in Rich Text Format: 

1. Open the QES file. 

2. In the file menu, select export, then interviews to Word…. 

3. Next to RTF file, click …, specify a location and filename for the data file you 
want to create, and click save. 

4. Set the options as follows: 
Option Description 

Create one file per interview Select this if you want a separate RTF 
file for each interview; otherwise, the 
interviews will be appended to the 
same file. 
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Option Description 

Export a selection of questions 

 

Select this if you want to export only 
certain questions from the interview. In 
the adjacent list, select the questions 
you want to export. 

 

5. Select which data is exported, by setting the following options:  
Option Description 

Export completes only Select this if you don’t want to export 
incomplete interviews. 

Interview started after 

 

You can select a date here, to export 
only the interviews that began after this 
date. 

Additional filter Here, you can specify a filter, written in 
askiascript, if you want to export only a 
subset of the data. Askiascript is 
beyond the scope of the course; please 
refer to the askiadesign Assistant for 
details. 

 

6. Click OK to begin the export.  

Setting the language that is exported 

à Explain that you can set which questionnaire version (language) is exported when 
you do exports from Tools. 

à Select Edit -> Current Language and demonstrate language selection. 

à Use the file example_export_interviews_to_word, do an export to Word™ in a 
different language from the one you did earlier (for example, if you did an export in 
English, now do one in French). 

o If you skipped exporting interviews to Word™, then repeat an export you have 
already done, in a different language. 

n Notes for participants 

For multi-lingual questionnaires, you can choose which version is exported from 
askiatools (in other words, which language is exported). 

To set the language to be exported: 

1. Open the QES file. 

2. In the edit menu, select current language …. The languages dialog appears. 

3. Select the language you want to export, and click OK. Any exports from this 
QES will now be done in the language you selected.  
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Recap 
à Provide a two-minute summary of the topics covered and then prepare participants 

for the exercise. 

In this session, you have learned how to: 

• Export data in variety of formats, including triple-S, fixed-length ASCII, 
delimited ASCII, Dimensions and SAV 

• Export interviews to a directory 

• Export interviews to Word™ 

• Set which language is exported 

Practical exercises 
à Ask the participants to complete this exercise. For the files, either use the supplied 

exercise files for session 403, or a simplified “real” example from the client. 

In the following exercises, you will export data into multiple formats. 

Exercise 1: Exporting data in triple-S format 
Please follow these steps: 

1. In askiatools, open the file export_example.qes. 

2. In the file menu, select export data, then triple-S.... 
3. You are prompted to set up a column description, so click OK. 

4. Right-click in the data map grid and select generate. Then click OK to set up 
the map. 

5. In the file menu, again select export data, then triple-S.... 
6. Next to target, click …, specify a location and filename for the data file you 

want to create, and click save. 

7. Click OK to carry out the export. 

8. Open the resulting file in a text editor or XML editor, if one is available on your 
computer. 

Exercise 2: Exporting data in SPSS SAV format 
Please follow these steps: 

1. In askiatools, open the file export_example.qes. 

2. In the file menu, select export, then SPSS sav format…. 
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3. Next to SAV file, click …, specify a location and filename for the data file, and 
click save. 

4. For this export, we’ll export only completed interviews. Select export 
completes only.  

5. Click OK to begin the export.  

Exercise 3: Exporting data to delimited ASCII 
Please follow these steps: 

1. In askiatools, open the file export_example.qes. 

2. In the file menu, select export, then delimited ASCII…. 

3. Next to ASCII file, click …, specify a location and filename for the data file 
you want to create, and click save. 

4. In question separator, select {TAB}. 
5. In multiple responses separator, select comma. 

6. If you are familiar with askiascript, write an additional filter for this export 
(otherwise, skip to step 7). Click … and enter your filter. For example, it could 
be ??i1. Gender?? Has(2)to include only females in your export, if your 
QES has that variable. Use the compile button to check the validity of your 
filter’s syntax before you apply it. 

7. Click OK to begin the export.  

8. Open the file in Excel™, if it is available, or in a text editor. 

Exercise 4: Exporting interviews to Word 
Please follow these steps: 

1. In askiatools, open the file example_export_interviews_to_word.qes. 

2. In the file menu, select export, then interviews to Word…. 

3. Next to RTF file, click …, specify a location and filename for the data file you 
want to create, and click save. 

4. In export questions, select a selection of questions. 

5. Click OK to begin the export. You will be prompted to select the questions you 
want to export. Choose which questions you want to export, and ensure they 
are in the right-hand list; remove any questions from the right-hand list by 
selecting them and clicking the left-pointing arrow: 

 
6. Click OK. The export is carried out. 

7. If Word, or another Word processor is available, open the RTF file. 
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Session 404  Survey file maintenance 

Outline 

Topics 
In this session, we will focus on 

• Verifying the data structure 

• The delete interview set of commands 

• Compacting and repairing the data 

• Reducing the space used by multi-coded questions 

• Reordering or deleting questions in your QES 

Learning outcomes 
At the end of this session you will be able to: 

• Perform a variety of checks and repairs on your QES 

• Restructure your questionnaire based on the structure of an external file 

• Optimize QES files by removing redundant space 
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Tutorial 

Verifying the data structure after adding a new question 
Verifying the data structure. 

à Explain: 

o QES files may get corrupted if you have run edits or made changes. You must 
verify the data structure whenever you add a question after fieldwork is 
complete.  

o You don’t need to verify the data during fieldwork, as data is automatically 
verified then. 

o Each question in the database contains two fields: one for the timing, one for the 
data. If you add a question (after fieldwork is complete), only one field is created, 
so you need to verify the data to correct this. For example, you might add a new 
single-coded question to store coded data based on a numeric age question. 

o If you generate random data, this also does a verify automatically. 

à Demonstrate verify: 

o Open the QES verify.qes. 

o Select Edit -> Verify data structure… 

n Notes for participants 

In some circumstances, QES files can become corrupted if you have run edits or 
made changes to them. You should verify the data structure whenever you add a 
question after fieldwork is complete.  

Each question in the database contains two fields: one for the timing, one for the 
data. If you add a question after fieldwork is complete, only one field is created, 
so you need to verify the data to correct this. For example, you might add a new 
single-coded question to store coded data based on a numeric age question. 

Note that: 

• during fieldwork you don’t need to verify the data when you add a 
question, as data is automatically verified in this situation; 

• if you generate random data, the data is also verified automatically at this 
point. 

To verify the QES data structure: 

1. Open the QES file. 

2. In the edit menu, select verify data structure…. 
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Deleting all interviews 
Deleting all interview data from the QES. 

à Explain that you may want to remove all interview data from the QES. For example, 
you might want to base a new QES on an existing one, to create a similar project, or 
a new wave, and don’t want the data from the original in the new QES. 

à Demonstrate delete all interviews: 

o Open the QES delete_all.qes. 

o Select Edit -> Delete all interviews. 

n Notes for participants 

If you want to clear all interview data from a QES, you can do so easily in 
askiatools. 

Warning: This action cannot be undone, so always ensure you have a backup of your 
data before running this command. 

 

To delete all interviews from the QES: 

1. Open the QES file. 

2. In the edit menu, select delete all interviews. 

3. You are asked to confirm the deletion. Note that this command cannot be 
undone, so always ensure you have a backup of your data before deleting 
any interviews. If you are sure you want to delete the interviews, select yes. 

Deleting incomplete interviews 
Deleting incomplete interview data from the QES. 

à Explain that you may want to remove incomplete interviews, if you are not interested 
in this data, and want a QES that is easier to work with. 

à Demonstrate delete uncompleted interviews: 

o Open the QES delete_incomplete.qes. 

o Select Edit -> Delete uncompleted interviews. 
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n Notes for participants 

You can easily delete any incomplete interviews from your QES with askiatools. 
This is useful if you are not interested in the incomplete interviews, as it can make 
the data set easier to work with. 

 

Warning: This action cannot be undone, so always ensure you have a backup of your 
data before running this command. 

 

To delete incomplete interviews from the QES: 

1. Open the QES file. 

2. In the edit menu, select delete uncompleted interviews. 

3. You are asked to confirm the deletion. Note that this command cannot be 
undone, so always ensure you have a backup of your data before deleting 
any interviews. If you are sure you want to delete the interviews, select yes. 

Deleting a selection of interviews 
Deleting specific interview data from the QES. 

à Explain that you can delete a selection of interviews from the QES. This might be 
interviews conducted within a specific date range, or in accordance with a custom 
filter. 

à Demonstrate deleting a selection of interviews: 

o Open the QES delete_selection.qes. 

o Select Edit -> Delete a selection of interviews… 

o Discuss the various options: 

§ Date range (Interview started after and Interview started before). 

§ Additional filter: this allows you to delete a subset of the data – e.g. 
respondents who were screened out a certain question).  

- Filter definition is written in askiascript, and is beyond the scope of this 
course. It is covered in depth in the askiascript course, and in the 
askiadesign Assistant. 

- An example filter is as follows: 
 
Q1 Has(2) 
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would delete only those records where response 2 was given at Q1. 

n Notes for participants 

You can delete selected interview data from the QES. This might be: 

• incomplete interviews; 

• completed interviews; 

• interviews that took place in a specific date range; 

• interviews based on a custom askiascript filter, or 

• a combination of these (e.g. incomplete interviews that took place 
between October 1st and October 8th, where response 5 was selected at 
variable Q3).  

 

Warning: This action cannot be undone, so always ensure you have a backup of your 
data before running this command. 

 

To delete a selection of interviews from the QES: 

1. Open the QES file. 

2. In the edit menu, select delete a selection of interviews…. 

3. Select the options as follows: 
Option Description 

Incompletes Select this if you want to delete incomplete 
interviews. 

Completes Select this if you want to delete completed 
interviews. 

Interview started after 
(including) 

If you select this, then specify a date, only the 
interviews that began on or after this date will be 
deleted. 

Interview started before 
(excluding) 

If you select this, then specify a date, only the 
interviews that began before (but not on) this date 
will be deleted. 

Additional filter Here, you can specify a filter, written in askiascript, 
if you want to delete only a subset of the data. 
Askiascript is beyond the scope of the course; 
please refer to the askiadesign Assistant for 
details. 

 

4. Click OK to delete the interviews. If any interviews met your criteria, 
askiatools will prompt you to confirm the deletion (the number of interviews 
that will be deleted is shown in the confirmation dialog). Note that this 
command cannot be undone, so always ensure you have a backup of your 
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data before deleting any interviews. If you are sure you want to delete the 
interviews, click yes. 

Marking a selection of interviews as complete or 
incomplete 

Marking specific interviews as complete or incomplete. 

à Explain that you can set the status of interviews from complete to incomplete, or vice 
versa. This might be interviews conducted within a specific date range, or in 
accordance with a custom filter. 

à Explain that the procedure is the same for complete and incomplete. 

à Demonstrate marking a selection of interviews as incomplete: 

o Open the QES mark_incomplete.qes. 

o Select Edit -> Mark a selection of interviews as incomplete… 

o Discuss the various options: 

§ Date range (Interview started after and Interview started before). 

§ Additional filter: this allows you to mark a subset of the data. This would 
usually be a list of IDs. For example: 
 
??ID??=105 or ??ID??=106 or ??ID??=107 
 
A long list of IDs can be pasted in from Excel. 
 
You can also specify a range of numbers: 
 
??Unique-ID?? > 104 and ??Unique-ID?? <200 

o Enter the following additional filter 
 
??ID?? > 0 And ??ID?? < 10 

o Click OK to mark the interviews. 

o Explain that if you have an invisible “data quality phase” question, you can use it 
as a flag to mark interviews as incomplete in one go when the data is not good 
enough. 

n Notes for participants 

You can mark a selection of interviews as either complete or incomplete. This can 
be interviews that took place within a certain date range, or according to a custom 
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filter. The procedure is the same for marking both complete and incomplete 
interviews. 

To mark a selection of interviews as complete or incomplete: 

1. Open the QES file. 

2. In the edit menu, select mark a selection of interviews, then complete… or 
incomplete…, as appropriate. 

3. Select the options as follows: 
Option Description 

Interview started after 
(including) 

If you select this, then specify a date, only the interviews 
that began on or after this date will be marked as 
complete/incomplete. 

Interview started 
before (excluding) 

If you select this, then specify a date, only the interviews 
that began before (but not on) this date will be marked 
as complete/incomplete. 

Additional filter Here, you can specify a filter, written in askiascript, if 
you want to mark as complete/incomplete only a subset 
of the data.  

For example: 

??Unique-ID??=105 or 106 or 107 
 
A long list of IDs can be pasted in fromExcel. 
 
You can also specify a range of numbers: 

??Unique-ID?? > 104 AND ??Unique-ID?? < 
200 

Askiascript is beyond the scope of the course; please 
refer to the askiadesign Assistant for details. 

 

4. Click OK to mark the interviews. If any interviews met your criteria, askiatools 
will prompt you to confirm your choice (the number of interviews that will be 
affected is shown in the confirmation dialog). Note that this command cannot 
be undone, so be sure you want to make this change running this command. 
If you are sure you want to mark the interviews, click yes. 

Using “mark and set value” to record completion status 
Changing the completion status of interviews with “mark and set value”. 

à Explain that you can set the completion status of interviews, based on the content of 
the data. In our example, we are going to mark interviews as incomplete, where the 
respondent completed the survey very quickly, and we feel they “raced” through. 

à Open the QES mark_and_set_value_example.qes in askiadesign, and show the 
structure. 

o Show the variable length_of_interview, and explain that this stores (via a routing) 
the number of seconds it took for each respondent to complete the interview. 
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à Open the QES in askiaanalyse, and show the values in the length_of_inteview 
variable. Point out that: 

o the mean number of seconds to complete the interview was 18.94; 

o most respondents completed the interview taking somewhere between 13 and 
50 seconds; 

o there are around 10 respondents who completed the interview in 10 seconds or 
less. 

o Let’s assume that the 10 respondents who completed the interview in 10 
seconds or less were “speeders”, who we want to exclude from our analysis. 

à Go back to askiadesign, and show the variable status. This has two responses: 
Complete and DQ failure (speeder). Explain that for every record where the 
respondent got to the end of the interview, this variable was set to Complete. 

o Explain that we could delete the “speeder” interviews, but it is safer and easier to 
mark them as incomplete. 

o We will use mark as incomplete to mark respondents who completed their 
interviews too quickly, by changing the value of status to DQ failure (speeder). 

à Explain that we should always make a back-up of the QES. Explain that this is good 
practice whenever you are going to alter data, as you always have the original data in 
the event that anything goes wrong. 

à In askiatools: 

o Open the QES. 

o Select edit, then mark a selection of interviews, then as incomplete…. 

o Next to additional filter section, click .,.. 

o In the condition dialog, enter the following: 

§ length_of_interview<11 

§ Explain that this identifies the respondents who took less than 11 seconds to 
complete the interview. 

§ Click OK. 

o Select set a value to a question. 

o In question, select status. 
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o In value, enter 2. 

o Click OK. 

o Click yes to confirm your action. 

n Notes for participants 

You can mark a selection of interviews as either complete or incomplete and set a 
value in a specific variable. This can be useful for recording custom completion 
statuses; for example, for marking interviews that are out of quota, or where the 
respondent raced through the interview. 

To mark and set value: 

1. This procedure permanently changes the data in your QES. As such, you 
should take a back-up of your QES file. In the event that you get unexpected 
results, you will then still have your original data. 

2. Open the QES file. 

3. In the edit menu, select mark a selection of interviews, then complete… or 
incomplete…, as appropriate. 

4. Select the options as follows: 
Option Description 

Additional filter Here, you can specify a filter, written in askiascript, if you want to 
mark as complete/incomplete only a subset of the data.  

For example: 

length_of_interview<11 

Askiascript is beyond the scope of the course; please refer to the 
askiadesign Assistant for details. 

Set a value to a 
question 

Allows you to set a value in a specific question, for the interviews 
identified by the filter. 

Question Specifies the question whose value you will be changing. For 
example, you might select completion_status. 

Value Specifies the value you will be storing in the question selected 
above, for all interviews identified by the filter. For example: 99. 

 

5. Click OK to mark the interviews. If any interviews met your criteria, askiatools 
will prompt you to confirm your choice (the number of interviews that will be 
affected is shown in the confirmation dialog). Note that this command cannot 
be undone, so be sure you want to make this change running this command. 
If you are sure you want to mark the interviews, click yes. 

Removing unused space from the QES 
Compacting and repairing the QES if it gets noticeably slow. 

à Explain: 
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o If you delete a lot of interviews from a QES, you can end up with a lot of empty 
space within the file. This can cause operations with the QES to be slow. 

o You can rectify this with the compact and repair utility in askiatools. 

à Demonstrate: 

o Open the QES compact_example.qes. 

o Select Edit-> Delete uncompleted interviews. 44 interviews are deleted. 

o In Windows explorer, show the file size of this QES. 

o Select Edit -> Compact and repair database. 

o Again, show the file size; it is now smaller. 

n Notes for participants 

If you delete a lot of interviews from your QES, you can end up with a lot of empty 
space within the file. In this situation, analysis can sometimes get noticeably slow. 
You can improve the performance by compacting and repairing the file. This 
removes any unused space, making the file more efficient to work with. 

To remove unused space from the QES: 

1. Open the QES file. 

2. In the edit menu, select compact and repair database. 

Reducing multiple responses to fit 
Reducing the size taken by multi-coded questions, in order to reduce the QES file 
size. 

à Explain: 

o Multi-coded questions can result in unused space in the QES file, if the amount 
of space to store the data is not actually being used. For example, if a multi has 
20 responses, but no respondent ever selects more than 10 responses, then 10 
columns are wasted. 

o This utility sets the maximum number of responses in multis based on the actual 
values in the data, and reduces the file size accordingly. 

o This utility should only be used after fieldwork is complete. 

à Demonstrate: 

o Open the QES reduce_multi_example.qes. 
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o Demonstrate: select Tools-> Reduce multiple responses to fit. 

n Notes for participants 

After fieldwork is complete, multi-coded questions can cause unused space in the 
QES, if come of the responses were never selected by any respondents. If this is 
a large number of responses, it can be worth removing the unused space to 
improve the QES performance. 

For example, if a multi-coded question has 50 responses, but only 10 are ever 
selected, then 40 columns are wasted per record. 

Askiatools can set the maximum number of responses in multi-coded questions 
based on the actual values in the data, and reduce the file size accordingly. 

Warning: This action should only be done after fieldwork is complete; you do not want to 
remove responses from the QES while they can potentially be selected by respondents. 

To reduce the space taken by multiple responses: 

1. Open the QES file. 

2. In the tools menu, select reduce multiple responses to fit. 

Reordering questions based on a matching file 
Reordering the questions in the QES file, based on the contents of a file. 

à Explain: 

o You can re-sequence the questions in the QES, based on the contents of a text 
file.  

o If you want to make a few changes to the question order, you could use 
askiadesign. 

o However, to quickly change the order of many questions, you can use this 
command. 

o It also lets you change the question order if you do not have a license for 
askiadesign. 

o You need to create a text file, containing the shortcuts of the questions and 
chapters in the desired order. 

§ Each line should contain two shortcuts, separated by a tab. 

§ If a variable is being indented inside another, the parent variable should be 
first, then a tab character, then the variable to be indented. 
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§ If the variable is not being indented, simply include its shortcut on the line 
twice, separated by a tab. 

§ For example: 
 
Demographics Age 
Demographics Gender 
Q1 Q1 
Q2 Q2 

à Demonstrate: 

o Open the QES Re-Order.qes. 

o Show the questionnaire structure in askiatools. 

o In a text editor, open the file Re-Order.txt and show the contents. 

o In askiatools, select Tools-> Reorder questions with matching file…. 

o Select the file re-order_example.txt. 

o Show the new questionnaire structure. 

n Notes for participants 

You can change the order of the questions in a QES file, based on the contents of 
an external text file. If you need to make a few changes, you could use 
askiadesign. However, askiatools allows you to change the order of many 
questions in one quick operation, whether or not you have a license for 
askiadesign. This feature is also very useful if you often perform the same 
question order change on similar QES files. 

In order to perform this operation, you need to create a text file containing the 
shortcuts of the questions and chapters in the desired order, as follows: 

• Each line should contain two shortcuts, separated by a tab. 

• If a variable is to be indented inside another, the parent variable should be 
first, then a tab character, then the variable to be indented. 

• If the variable is not being indented, simply include its shortcut on the line 
twice, separated by a tab. 

• For example: 
 
Demographics Age 
Demographics Gender 
Q1 Q1 
Q2 Q2 
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To re-order to the QES, based on the contents of an external file: 

1.  Ensure you have prepared your text file, as described above. 

2. Open the QES file. 

3. In the tools menu, select reorder questions with matching file…. 

4. Select the external file and click open. 

Deleting a list of questions from the QES 
Deleting questions listed in a file. 

à Explain: 

o You can delete a list of questions from the QES, based on the contents of an 
XML file.  

o This utility lets you remove questions if you do not have a license for 
askiadesign. 

o This utility is also useful if you often remove similar lists of questions (e.g. you 
have similar QES files, such as different waves of a study). 

o You need to create an XML file, containing the shortcuts of the questions and 
chapters you want to delete. For example: 
 
<?xml verion=”1.0” encoding=”Unicode” ?> 
<SuppressedVariables> 
 <SuppressedVariable>q1</SuppressedVariable> 
 <SuppressedVariable>q8</SuppressedVariable> 
</SuppressedVariables> 

à Demonstrate: 

o In a text editor, open the file delete _example.xml and show the contents. 

o In askiatools, open delete_example.qes. 

o Select Tools-> Delete questions with a matching file…. 

o Select the file delete_example.xml. 

o Show the questionnaire structure now. 

n Notes for participants 

You can delete a list of questions from the QES, based on the contents of an 
external XML file. This feature lets you remove questions even if you do not have 
a license for askiadesign. This feature is also very useful if you often remove 
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similar lists of questions (e.g. you have similar QES file, such as different 
instalments of a diary study). 

The structure of the file should be as follows (in the following example, variables 
q1 and q8 are to be deleted): 

 
<?xml verion=”1.0” encoding=”Unicode” ?> 
<SuppressedVariables> 
 <SuppressedVariable>q1</SuppressedVariable> 
 <SuppressedVariable>q8</SuppressedVariable> 
</SuppressedVariables> 

 

To delete a list of questions from the QES: 

1.  Ensure you have prepared your XML file, as described above. 

2. Open the QES file. 

3. In the tools menu, select delete questions with a matching file…. 

4. Select the external file and click open. 

Rebuilding the questionnaire based on the contents of a 
file 

Restructuring the questionnaire, based on the contents of a file. 

à Explain: 

o You can restructure the QES, based on the contents of an XML file.  

o This utility lets you restructure the QES if you do not have a license for 
askiadesign. 

o Chapters that exist in the XML file, but not the QES, are added to the QES. 

o When a question exists in the XML, but not the QES, a chapter is created in the 
QES with the same shortcut as the question. 

o When a question exists in the QES, but not the XML, it remains in the QES, 
located just after the first known preceding question in the source. 

à Demonstrate: 

o In turn, open restructure_example_a.qes, and restructure_example_b.qes and 
show how the structures differ (b has an extra question, Q6, and Q1 and Q2 are 
inside a chapter). 

o Open restructure_example_b.qes and select File-> Export XML Questionnaire. 
Save it as restructure_example.xml 
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o Open restructure_example_a.qes and select Tools-> Rebuild tree structure 
with matching file…. 

o Select the file you just created (restructure_example.xml). 

o Show that the questionnaire now matches the structure of 
restructure_example_b.qes  – except that Q6 has been created as a chapter, 
rather than a question. 

n Notes for participants 

You can change the structure of the QES, based on the contents of an external 
XML file. This feature lets you restructure the QES even if you do not have a 
license for askiadesign. This feature is also very useful if you often restructure 
similar projects (e.g. you have similar QES file, such as different instalments of a 
diary study). 

The QES is restricted as follows: 

• When a chapters exists in the XML file, but not the QES, it is added to the 
QES; 

• When a question exists in the XML, but not the QES, a chapter is created 
in the QES with the same shortcut as the question; 

• When a question exists in the QES, but not the XML, it remains in the 
QES, located just after the first known preceding question in the source. 

You can export a questionnaire as XML in order to apply its structure to another 
QES. See Exporting the questionnaire in XML format on page 46 for details on 
exporting as XML. 

To restructure the QES based on an external XML file: 

1.  Ensure you have prepared your XML file, as described above. 

2. Open the QES file. 

3. In the tools menu, select rebuild tree structure with matching file…. 

4. Select the external file and click open. 

Recap 
à Provide a one-minute summary of the topics covered and then prepare participants 

for the exercise. 

In this session, you have learned how to: 

• Delete interviews from the QES 

• Mark interviews as complete or incomplete 

• Remove unused space from the QES 

• Reorder or delete questions based on the contents of a file  
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Practical exercises 
à Ask the participants to complete this exercise. For the files, either use the supplied 

exercise files for session 404, or a simplified “real” example from the client. 

Please do the following exercises. 

Exercise 1: Verifying the data structure after the 
questionnaire has changed 

Please follow these steps: 

1. Take the file verify.qes, and make a copy of it, adding “_1” to the name (so it 
becomes verify_1.qes). 

2. Open the new QES in askiadesign, and add a new question of your choice. 
Save your changes, and close askiadesign. 

3. Open the new QES in askiatools. 

4. In the edit menu, select verify data structure…. 

Exercise 2: Marking interviews as incomplete 
Please follow these steps: 

1. Open mark_incomplete.qes in askiatools. 

2. In the edit menu, select mark a selection of interviews, then incomplete…. 

3. Next to additional filter, click …. 

4. Enter a condition that references a range of interviews (e.g. records 50-70).  

5. Click OK. When you are asked to confirm your action, answer yes. 

Exercise 3: Deleting specific interviews from the QES 
Please follow these steps: 

1. Open the file delete_selection.qes in askiatools. 

2. In the edit menu, select delete a selection of interviews…. 

3. Next to additional filter, click …. 

4. Enter a filter that references a range of interviews (e.g. interviews 1-5).  

5. Click OK. When you are asked to confirm your action, answer yes. 

6. Open the QES provided by your tutor. 

7. In the tools menu, select reduce multiple responses to fit. 
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8. In the edit menu, select compact and repair database. 
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Session 405  Merging data 

Outline 

Topics 
In this session, you will learn how about: 

• Merge interviews  

• Merge questionnaires 

• Consolidate using ID 

• Overwrite data 

Learning outcomes 
At the end of this session, you will be able to: 

• Merge and consolidate records in your QES files 

• Combine records from different  QES files in various ways 

• Merge data across levels 

• Match and combine records using a unique identifier  

• De-duplicate QES files 

• Perform update runs to replace data that need to change 
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Tutorial 

Checking whether two QES files have identical structures 
Checking whether two QES files are “superposable” (i.e. have identical 
structures). 

à Explain: 

o When merging QES files, it is useful to know whether the two files are identical 
(“superposable”), and thus can be more easily merged.  

o Askiatools allows you to compare two QES files, to check whether they are 
identical or not. 

o Askiatools states whether the two files are identical. If not, you are prompted to 
save a report file, which will open automatically, describing the differences 
between the two QES files. 

à Demonstrate: 

o Open the first QES example_A_merge_interviews_1.qes. 

o Select Merge-> Compare files… 

o Select the second QES example_A_merge_interviews_2.qes. 

o This should show that the files are identical. If you want to demonstrate what 
happens when there are differences, run a compare with a different QES. 

n Notes for participants 

Askiatools can check whether two QES files have identical structures (this is 
known as “superposable”). This is useful when merging QES file, as identical files 
can be more easily merged. If the files are not identical, askiatools produces a 
text file containing a description of any differences between the files. 

To check whether two QES files have identical structures: 

1. Open the first QES file. 

2. In the merge menu, select compare files…. 

3. Select the second QES file, and click open. 

4. If the files are not identical, you will be prompted to save the report file, in text 
format. Specify a name and location for the text file, and click save. The 
report is generated, and opens automatically in an external text editor 
program. 
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Merging interviews from one QES into another 
à Explain: 

o This utility lets you merge interviews from one QES file into another.  

à Demonstrate: 

o Open the first QES example_A_merge_interviews_1.qes. 

o Select Merge-> Interviews… 

o In Askia file, select example_A_merge_interviews_2.qes. 

o If the QES files are “superposable”, i.e. identical, you should select assume 
questionnaires are superposable. 

§ As we have just checked that our example files are superposable, we can 
select this. 

§  If the QES files are not identical, you will need to select using shortcuts 
and entry codes or using internal question and response ids… 

- Internal question and response ids is useful if you are using the 
same questionnaire with different waves. A question could have a 
different name but the same internal id. To do so, you need to look at 
the database structure behind the scenes in Microsoft Access. 

n Notes for participants 

You can use askiatools to merge interviews from one QES into another. This is 
easier to do if the QES files are identical in structure. To check whether they are, 
you can run the compare files command. See Checking whether two QES files 
have identical structures on page 72 for details. 

To merge interviews: 

1. Open the target QES file (the file into which you want to merge the 
interviews). 

2. In the merge menu, select interviews…. 

3. Next to askia file, click open: 

 
4. Select the source QES file (the file containing the interviews you want to 

merge) and click open. 

5. If the two QES files have the same structure (See Checking whether two QES 
files have identical structures on page 72), select assume questionnaires 
are superposable. Otherwise, you will need to select using shortcuts and 
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entry codes or using internal question and response ids… as the basis 
for matching questions. 

6. Click OK to perform the merge. 

Merging two questionnaires 
Merging two QES files. 

à Explain: 

o This utility lets you merge questionnaires together. Any questions from the 
second QES are appended to the end of the first QES. 

o All of the interviews from the second QES are copied into the first QES, but you 
end up with separate records from each source QES, even if two records are for 
the same respondent. 

à Demonstrate: 

o Open the first QES example_B_merge_questionnaires_1.qes. 

o Show the structure of the QES. 

o Select Merge-> Questionnaires… 

o Select the second QES example_B_merge_questionnaires_2.qes. 

o Show the resulting questionnaire structure in askiatools. 

n Notes for participants 

You can use askiatools to merge interviews from one QES into another. 

• Any questions from the second (source) QES are appended to the end of 
the first (target) QES. 

• All of the interviews from the source QES are copied into the target QES, 
but note that you will end up with separate records from each QES, even if 
one record in each QES is for the same respondent. 

To merge two questionnaires: 

1. Open the target QES file (the file into which you want to merge the questions). 

2. In the merge menu, select questionnaires…. 

3. Select the source QES file (the file containing the questions you want to 
merge) and click open. 
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Merging two questionnaires matched by ID 
Merging two QES files, and matching the respondents with an ID question. 

à Explain: 

o This utility lets you merge questionnaires together. Any questions from the 
second QES are appended to the end of the first QES. 

o All of the interviews from the second QES are copied into the first QES, and you 
end up with one record per respondent. 

o Respondent records are matched by the ID question that you nominate, so if 
there are two records relating to the same respondent, they will be 
amalgamated.  

o This merge procedure also checks for duplicate records. 

à Demonstrate: 

o Open the first QES example_C_merge_questionnaires_using_ID_1.qes. 

o Show the structure of the QES. 

o Select Merge-> Questionnaires using ID… 

o In Askia file, select the second QES 
example_C_merge_questionnaires_using_ID_2.qes. 

o In Respondent ID in target, select Unique_ID. 

o In Respondent ID in source, select Unique_ID. 

o Click OK. 

o Show the resulting questionnaire structure in askiatools. 

n Notes for participants 

Askiatools allows you to merge two questionnaires, and match the records based 
on the values found in an ID question. 

• Any questions from the second (source) QES are appended to the end of 
the first (target) QES. 

• All of the interviews from the source QES are copied into the target QES, 
and you will end up with one record for each respondent. 

• Respondent records are matched by the ID question that you nominate, 
so if two records relate to the same respondent, they will be amalgamated. 
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• This procedure also checks for duplicate records. 

To merge two questionnaires using an ID variable: 

1. Open the target QES file (the file into which you want to merge the questions). 

2. In the merge menu, select questionnaires using ID…. 

3. Next to askia file, click open: 

 
4. Select the source QES file (the file containing the interviews you want to 

merge) and click open. 

5. In respondent ID in target, select the variable containing respondent IDs in 
the target QES. 

6. In respondent ID in source, select the variable containing respondent IDs in 
the source QES. 

7. Click OK to perform the merge. 

Merging two questionnaires to create one with two levels 
Merging one QES file into a second level of another, and matching the 
respondents with an ID question. 

à Explain: 

o This utility lets you create a new loop in a QES, containing data from a second 
QES. 

o The second QES file’s questions will be appended to the first QES file. 

o All of the interviews from the second QES are copied into the first QES, and you 
end up with one record per respondent. 

o Respondent records are matched by the ID question that you nominate, so if 
there are two records relating to the same respondent, they will be 
amalgamated.  

à Demonstrate: 

o Explain that we are going to merge a QES containing patient interviews into 
another QES with doctors, as a “patients” loop. 

o Open the following two Excel files and show the two sets of data: 

§ example_D_merge_level_data_doctor.xls 

§ example_D_merge_level_data_patient.xls 
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o Open the first QES example_D_merge_level_data_doctor.qes. 

o Show the structure of the QES. 

o Select Merge-> Questionnaire in new level using id… 

o In Askia file, select the second QES example_D_merge_level_data_patient.qes. 

o In Respondent ID in target, select DOCTOR. 

o In Respondent ID in source, select DOCTOR. 

o Click OK. 

o Show the resulting questionnaire structure in askiatools. 

n Notes for participants 

Askiatools allows you to merge one QES into a second level of another, matching 
the records based on the values found in an ID question. 

• This utility creates a new loop in the target QES, containing data from the 
source QES. 

• Any questions from the second (source) QES are appended to the first 
(target) QES. 

• All of the interviews from the source QES are copied into the target QES, 
and you will end up with one record for each respondent. 

• Respondent records are matched by the ID question that you nominate, 
so if two records relate to the same respondent, they will be amalgamated. 

To merge one questionnaire into a new level of a second questionnaire using an 
ID variable: 

1. Open the target QES file (the file into which you want to merge the questions). 

2. In the merge menu, select questionnaire in new level using ID…. 

3. Next to askia file, click open: 

 
4. Select the source QES file (the file containing the interviews you want to 

merge) and click open. 

5. In respondent ID in target, select the variable containing respondent IDs in 
the target QES. 

6. In respondent ID in source, select the variable containing respondent IDs in 
the source QES. 

7. Click OK to perform the merge. 



Course 400: Askia Tools Introductory Training • Coursebook with Tutor’s Notes 

78 

Consolidating duplicated data records 
Merging duplicate data records within a QES. 

à  Explain: 

o This utility lets you merge duplicate data records within a QES. 

o It is useful if you have a different set of questions in each QES file, but the same 
set of respondents in both (for example, questions 1 to 20 in the first QES and 
questions 21-40 in the second QES), and you have merged the QES files. 

o Respondent records are matched by the ID question that you nominate, so if 
there are two records relating to the same respondent, they will be 
amalgamated.  

o Doing a “Merge Questionnaires” operation, then a consolidate, is roughly the 
same as doing “Merge Questionnaires using ID”. 

à Demonstrate: 

o Open consolidate_using_id_example.qes. 

o Select Merge-> Consolidate using id… 

o Select Unique_ID as the ID question.  

o Click OK. 

n Notes for participants 

Askiatools allows you consolidate duplicate data records within a QES, based on 
the value in an ID variable. This command is useful if you have merged two QES 
files which had different sets of questions, but the same set of respondents (for 
example, questions 1 to 20 in the first QES and questions 21-40 in the second 
QES). 

• Respondent records are matched by the ID variable that you nominate, so 
if there are two records relating to the same respondent, they will be 
amalgamated. 

• Using this command after doing a merge questionnaires is roughly 
equivalent to using the merge questionnaires using ID command. 

To consolidate duplicate records within a QES: 

1. Open the QES file. 

2. In the merge menu, select consolidate using ID…. 

3. Select the question that you want to use as the ID variable. It will be used to 
match the records. Click OK. Askiatools performs the consolidation, and 
informs you as to how many interviews it has consolidated. 
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Overwriting data using an ID variable and shortcuts 
Overwriting data in one QES from another, matching with an ID question and 
short-cuts. 

à  Explain: 

o If you re-ask one or more questions, you might want to replace the data for those 
questions with data from the second (re-ask) QES. 

o This utility is useful for re-importing data after external coding has taken place. 

o You nominate the questions where the data will be replaced. 

o Delimited ASCII option is useful if you have ASCII with shortcuts etc. 

à Demonstrate overwriting from an Askia QES: 

o Open the QES 
example_E_merge_overwrite_data_using_ID_and_shortcuts_1.qes. 

o Select Merge-> Overwrite data using using id and shortcuts -> From an 
Askia QES file. 

o Nominate the file 
example_E_merge_overwrite_data_using_ID_and_shortcuts_2.qes. 

o In the question selection dialog, select Unique_ID. 

o Click OK. 

à Demonstrate overwriting from an ASCII file: 

o Open the first QES overwrite_data_from_ASCII.qes. 

o Select Merge-> Overwrite data using using id and shortcuts -> From a 
delimited ASCII file. 

o In Ascii file, select the file overwrite_data_from_ASCII.txt. 

o In ID question, select Unique_ID. 

o Click OK. 
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n Notes for participants 

Askiatools allows you to overwrite data in one QES with data from another, using 
an ID variable to identify records and question shortcuts to identify the questions. 
It is useful when: 

• you re-ask one or more questions in a study, and you want to replace the 
data for these questions with data from a second QES, which contains the 
re-asked question data; 

• you want to re-import data after external coding has taken place. 

You can overwrite data in a sub-set of the questions; you do not need to overwrite 
all the question data if you do not want to. You can overwrite the data from 
another QES file, or a delimited ASCII file that contains question shortcuts. 

To overwrite data using an ID and shortcuts from data in a QES file: 

1. Open the target QES file (the file into which you want to overwrite the data). 

2. In the merge menu, select overwrite data using ID and shortcuts, then 
from an Askia QES file. 

3. Select the source file (the file containing the data you want to copy into the 
target QES), and click open. 

4. Select the variable that contains the unique IDs that will be used to match the 
respondent records, and click OK. 

 

To overwrite data using an ID and shortcuts from data in a delimited ASCII file: 

1. Open the target QES file (the file into which you want to overwrite the data). 

2. In the merge menu, select overwrite data using ID and shortcuts, then 
from a delimited ASCII file. 

3. Next to ASCII file, click …, then select the source file (the file containing the 
data you want to copy into the target QES), and click open. 

4. Next to ID question, click …, and select the variable that contains the unique 
IDs that will be used to match the respondent records; then, click OK. 

5. Click OK to perform the overwrite operation. 

Recap 
à Provide a one-minute summary of the topics covered and then prepare participants 

for the exercise. 

In this session, you have learned how to: 

• Merge questionnaires together. 

• Check whether two QES files have identical question structures. 

• Merge questionnaires and data based on ID. 

• Consolidate data within a QES file. 
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• De-duplicate a QES file. 

• Overwrite data in one file based on the data in another file. 
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Practical exercise 
à Ask the participants to complete this exercise. For the files, either use the supplied 

exercise files for session 405, or a simplified “real” example from the client. 

Please do the following exercises; your tutor will tell you which files to use. In 
these exercises we are updating a QES, adding more data from a follow-up set of 
interviews with the original respondents, containing in a second QES. First, we 
will check for duplicate records in the first QES, before we merge in the new data 
from the second QES. 

Merging in follow-up data  
Please follow these steps: 

1. In askiatools, open the file merge_questionnaires_using_ID_1.qes. 

2. In the merge menu, select delete duplicates using id…. 

3. Select Unique_ID and click OK. 

4. In the merge menu, select questionnaires using ID…. 

5. Next to askia file, click open: 

 
6. Select the file merge_questionnaires_using_ID_2.qes and click open. 

7. In respondent ID in target, select Unique_ID. 

8. In respondent ID in source, select Unique_ID.. 

9. Click OK to perform the merge. 
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Session 406  Data management 

Outline 

Topics 
In this session, you will learn about: 

• Generate random interviews 

• Export a report of response timings 

• Export multimedia files 

• Repair data problems resulting from poorly encoded character sets 

• Automate tasks from the command line 

Learning outcomes 
At the end of this session, you will be able to: 

• Generate random interview data when testing your survey’s logic 

• Use the command line to automate a variety of askiatools tasks 
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Tutorial 

Generating random interview data 
How to generate random interview data. 

à Explain that it is useful to generate random data in order to test the survey before 
fieldwork begins. Because the randomised interviews follow the routing logic, you can 
perform data analysis in askiavista or askiaanalyse to check for errors in the routing 
logic. 

à Demonstrate: 

à Open generate_random.qes. 

à Select Tools -> Generate random interviews…. 

à Accept the defaults, but explain: 

o Number of interviews is the number of records that will be generated. 

o Number of attempts per question allows askiatools to try again with different 
values to get around blocking message routing that occurs as a result of the 
selected response. For example, if you enter 10, askiatools will try up to a further 
9 times if it selects a response that is blocked. 

o If you have routing that relate to quotas, the quota needs to be set. You need a 
SQL connection string to the AskiaField database, and the quota keywords need 
to be set. There is a Knowledge Base article covering this in depth: 
 
support.askia.com/hc/en-
us/search?utf8=%E2%9C%93&query=random+data+generation 

n Notes for participants 

It is often useful to generate random interview data, in order to test the survey 
routing before fieldwork begins. Because askiatools’ randomised interviews follow 
the survey’s routing logic, you can perform data analysis in askiavista or 
askiaanalyse to detect errors in the routing. 

To generate random interview data: 

1. Open the QES file. 

2. In the tools menu, select generate random interviews…. 

3. In number of interviews, enter the number of records you want to generate. 

4. Number of attempts per question defines the number of tries that the 
random generator will make to answer a question where routing blocks 
progress. For example, if you set this value to 5 , the generator will select a 
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random response, and if the routing blocks progress, it will try up select 
random responses up to four more times (for a total of five attempts) in order 
to get past the blocking routing. You can enter a value up to 100. 

5. Click OK. 

 

The Knowledge Base contains further information on Random Generation, 
including detailed information about the various fields and options available. You 
can find this article, by going to support.askia.com/hc/en-
us/search?utf8=%E2%9C%93&query=random+data+generation 

 

Reporting on respondent response times 
Producing a report containing respondent answering times. 

à Explain: 

o You can use askiatools to create a report on how long it took respondents to 
answer the questions in the QES. 

o This helps eliminate interviews with very long response times (which might affect 
the average), or very quick responses (a Web respondent did not read the 
questions). 

o Timings are shown in seconds. 

o It is also possible to produce a timing report in askiaanalyse. 

à Demonstrate: 

o Open the QES training.qes. 

o Select Tools -> Export question timing… 

o Specify a name for the report file. 

o Show the report on screen. 

n Notes for participants 

Askiatools can produce a report on how long it took respondents to answer the 
questions in a QES. This helps you to eliminate interviews with very long 
response times (which might affect the average) or very quick responses (e.g. a 
Web respondent who did not read the questions and just selected random 
answers). The report shows timings for each question in seconds. 
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To produce a report on respondent answering times: 

1. Open the QES file. 

2. In the tools menu, select export question timing…. 

3. Specify a location and name for the report file, and click save. The report is 
generated, and opens automatically in an external text editor program. 

Exporting multimedia files from askiaface 
Exporting multimedia files attached to open-ended questions in askiaface data. 

à Explain: 

o You can export multimedia files that are attached to open-ended questions, in 
askiaface data. 

o You can apply filters to determine which interviews are selected. 

o One file is exported for each question. 

à Demonstrate: 

o Open the QES example_export_media.qes. 

o Select Tools -> Export multimedia files. 

o In directory, select an appropriate output folder. 

o In questions, select the question photo. 

o Accept the default settings, but briefly discuss the various options: 

§ Export completes only: files associated with incomplete interviews will not 
be exported. 

§ Interview started after: allows you set a start date; files in interviews before 
this date will not be exported. 

§ Additional filter: this allows you to export files associated with a subset of 
the data. 

n Notes for participants 

Askiatools allows you to export multimedia files that are attached to open-ended 
questions in askiaface data. You can apply filters to determine which interviews 
are selected. One file is exported for each question. 
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To export askiaface multimedia files: 

1. Open the QES file containing the multimedia files. 

2. In the tools menu, select export multimedia files from open…. 

3. Next to directory, click …, select the folder into which the files will be saved. 
and name for the report file, and click OK. 

4. Next to questions, click …. The question selection dialog opens. 

5. Move the questions from which you want to export the files into the right-hand 
list, by selecting them and clicking the right-facing arrow. Note that you can 
only move open text questions into the right-hand list. 

6. When you are satisfied with the selection of questions in the right-hand list, 
click OK. 

7.  Select which records the files are to be exported from, by setting the 
following options:  
Option Description 

Export completes only Select this if you don’t want to export files from 
incomplete interviews. 

Interview started after 

 

You can select a date here, to export only from 
interviews that began after this date. 

Additional filter Here, you can specify a filter, written in askiascript, if 
you want to export only from a subset of the data. 
Askiascript is beyond the scope of the course; 
please refer to the askiadesign Assistant for details. 

 

8. Click OK to perform the export. Askiatools exports the files, and informs you 
how many files were exported. 

Repairing character encoding in Web survey data 
Repairing poorly encoded characters in Web survey data. 

à Explain: 

o Web survey data might contain more than one character set, but this might not 
always be encoded correctly. 

o We can use askiatools to remedy this. 

o This utility is mainly used on historical data, as recent versions of askiafield now 
handle multiple character sets better.  

o Explain that Translate &#nnn; in questionnaire…. fixes HTML character 
encodings in the questionnaire itself. 
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o Explain that Tools -> Translate &#nnn; in interviews…. fixes HTML character 
encodings in the interview data. 

n Notes for participants 

Web survey data sometimes contains more than one character set, and this may 
sometimes not be encoded correctly. Askiatools can repair this. 

Note that recent versions of askiafield have improved handling of multiple 
characters sets, so you should not need to use this utility on data collected in 
recent versions. 

To repair the character encoding in Web survey data: 

1. Open the QES file containing the data you want to repair. 

2. In the tools menu, select translate &#nnn; in questionnaire…. This repairs 
HTML encoding in the questions and responses. 

3. In the tools menu, select translate &#nnn; in interviews…. This repairs 
HTML encoding in the data. 

Automating tasks 
Running askiatools utilities from the command line. 

à Explain: 

o Almost any askiatools command can be run from the command line. 

o This can be used in tandem with askiavista’s scheduled tasks. 

o For example, to import .dat files from the command line into a QES file, you 
would use the following syntax: 
 
AskiaToolsU.exe "C:\my directory\My Qes File.qes" 
/importdat /datafile:"c:\The directory with the .dat" 

o You can apply a command to multiple files with the FORFILES command: 
 
FORFILES /S /M *.qes /C "cmd /S /C ^0x22C:\Program^ Files^ 
^0x28x86^0x29\Askia\AskiaToolsU.exe^0x22 @PATH 
/deleteinterviews /completes /incompletes" 

o You can also repeat a set of commands by putting them into a batch file.  

o Full details can be found at https://support.askia.com/hc/en-
us/articles/200003451-Automate-tasks-via-Command-line. 

n Notes for participants 

Almost any askiatools command can be run from the command line. For example, 
to import .dat files from the command line into a QES file, you would use the 
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following syntax: 
 
AskiaToolsU.exe "C:\my directory\My Qes File.qes" /importdat 
/datafile:"c:\The directory with the .dat" 

You can apply a command to multiple files with the FORFILES command: 
 
FORFILES /S /M *.qes /C "cmd /S /C ^0x22C:\Program^ Files^ 
^0x28x86^0x29\Askia\AskiaToolsU.exe^0x22 @PATH 
/deleteinterviews /completes /incompletes" 

You can also repeat a set of commands by putting them into a batch file.  

Full details can be found at https://support.askia.com/hc/en-
us/articles/200003451-Automate-tasks-via-Command-line. 

This feature can be used in tandem with askiavista’s scheduled tasks, so that you 
can trigger askiatools commands on a schedule from within askiavista. 

Recap 
In this session, you have learned: 

• How to generate random interview data. 

• How to produce reports on respondent answering times. 

• Exporting askiaface multimedia files. 

• Automating tasks with the command line. 
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Practical exercises 
à Ask the participants to complete this exercise. For the files, either use the supplied 

exercise files for session 406, or a simplified “real” example from the client. 

Please do the following exercises; your tutor will tell you which files to use. 

Exercise 1: Generating random data 
Please follow these steps: 

1. In askiatools, open the QES file your tutor provides. 

2. In the tools menu, select generate random interviews…. 

3. In number of interviews, enter 100. 

4. Click OK. 

Exercise 2: Exporting questions timings and multimedia 
files 

1. In askiatools, open the file export_timings.qes. 

2. Export the question timings from this QES. 

3. Open the file example_export_media.qes. 

4. Export the multimedia files. 
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Session 407  Verifying and coding data 

Outline 

Topics 
In this session, you will learn about: 

• Postcode open-ended questions 

• Incomplete data analysis 

Learning outcomes 
At the end of this session, you will be able to: 

• Perform coding from within Tools 

• Run checks for incomplete data 
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Tutorial 

Coding open-ended questions 
Using askiatools to carry out coding. 

à Explain: 

o Askiatools allows you to code open-ended questions. 

o Askia recommends that you used KODIM for coding, as that is more powerful, 
and more controlled, but you can use askiatools. 

à Demonstrate: 

o Open the QES training.qes. 

o Select the question Q15 – Ideal trip. 

o Select Tools -> Post-code an open question… 

o Enter the shortcut Q15 (post-coded) and click OK. 

o Explain the coding interface: 

§ Stepping through the interviews. 

§ Adding a new code. 

§ Selecting a code for the question. 

n Notes for participants 

Askia recommends that you use KODIM to code open-ended questions. 
However, you can do your coding in askiatools. 

To carry out coding in askiatools: 

1. Open the QES file you want to code. 

2. In the questionnaire view, select the question you want to code. This must be 
an open text question. 

3. In the tools menu, select post-code an open question…. 

4. If you have not already done coding on this question, you will prompted to 
enter a shortcut for the new, coded question that will be created. Enter the 
shortcut, and click OK. 
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5. In the right-hand pane, you can define and select responses to the new 
closed question. The left-hand pane shows the data in the open question. 
Step through the records and code the responses by selecting the appropriate 
responses. 

6. Navigate through the records as follows: 
 

 
7. To add a new response, click ins, enter the response text and click OK. 

8. To select one or more responses for the current record, click the checkbox 
next to it. To de-select a response, simply click the checkbox to clear it. 

9. To change a response caption, click the response and then click Ab. Type the 
new label for the response, and click OK. You should be very careful when 
doing this for responses that have already been selected, as you could 
change the meaning of coding that has already been done. 

10. When you have finished coding the question, click OK. 

Reporting on incomplete data 
Reporting on incomplete data. 

à Explain: 

o You can produce a report that shows whether records are complete (e.g. drop-
outs in Web surveys). 

o The report checks the data against the questionnaire’s routing. 

o The report will be based on the latest version of the routing in your 
questionnaire. 

à Demonstrate: 

o Open the QES training.qes. 

o Select Tools -> Incomplete data analysis … 

o Nominate an output file, and talk through the options: 

§ Additional info 

§ Show summary of completes per question 

Go to first 
interview

Go to last 
interview

Go to next 
interview

Go to previous 
interview
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o Run the report, and show it on screen. 

n Notes for participants 

Askiatools can produce a report on whether records are complete. The report 
checks the data against the questionnaire’s routing and identifies records that 
have not reached the end of the interview by a valid path. An example of use 
would be for identifying web interviews where the respondent dropped out before 
completing the interview. 

Note that the report is checked against the latest version of the routing, so if the 
routing changed mid-way through fieldwork, earlier records may be incorrectly 
identified as complete or incomplete. 

To produce a report on incomplete data: 

1. Open the QES file. 

2. In the tools menu, select incomplete data analysis…. 

3. Next to output file, click …, select the location and filename of the report file 
you want to create, and click save. 

4. In additional info, select as follows: 

• No information about interview: the report contains information about 
the number of incomplete interviews for each question. 

• Show interview information with each question: the report contains 
information about the number of incomplete interviews for each question, 
along with the interviewID and the start/end interview time. 

• Show interview information after question summary: the report 
contains information about the number of incomplete interviews for each 
question, and then, after the question summary, the interviewID and 
start/end interview time. 

5. Click OK to run the report. 

Data editing 
Running data edit script. 

à Explain: 

o You can create and run various data editing scripts, to repair data. These can be 
run after fieldwork but before data analysis, or where necessary during fieldwork. 

o Askia offers another course – Data Edits – that covers this functionality. 

§ If you are going to run the Data Edits course with them, explain this. 

o Explain that there is a Knowledge Base article that covers data edits in more 
detail, with downloadable examples. It can be found at: support.askia.com/hc/en-
us/search?utf8=%E2%9C%93&query=edit+routings 
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n Notes for participants 

It is possible to create and run special scripts that carry out data checking. They 
are created in askiadesign and then run in askiatools. They are beyond the scope 
of this course, but Askia offers a separate data edits course that we recommend 
you take if you are likely to use this functionality. 

More information on the concepts involved in running “edits” routings, with 
downloadable examples, can be found in the Askia Knowledge Base. You can 
find this article by going to support.askia.com/hc/en-
us/search?utf8=%E2%9C%93&query=edit+routings 

Recap 
In this session, you have learned how to: 

• Code open questions 

• Produce a report on incomplete interviews 
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Practical exercises 
à Ask the participants to complete this exercise. For the files, either use the supplied 

exercise files for session 407, or a simplified “real” example from the client. You will 
need to nominate a question for the participants to code for the second exercise. 

Please complete the following exercises. Your tutor will tell you which files to use. 

Exercise 1: Generating random data 
Firstly, let’s generate some random interview data in a QES. 

Please follow these steps: 

1. In askiatools, open the QES file your tutor provides. 

2. In the tools menu, select generate random interviews…. 

3. In number of interviews, enter 100. 

4. Click OK to generate the interviews. 

Exercise 2: Coding open questions 
Now, code an open question. 

Please follow these steps: 

1. In askiatools, open the QES file your tutor provides. 

2. In the question tree, select the question you are going to code (your tutor will 
nominate one). 

3. In the tools menu, select post-code an open question…. 

4. Enter an appropriate question shortcut, and click OK. 

5. Use the coding interface to code a few responses. 

6. Click OK when you have finished. 

Exercise 3: Running checks on the QES 
Next, let’s run an incomplete data analysis on the QES. 

Please follow these steps: 

1. In askiatools, open the QES file your tutor provides. 

2. In the tools menu, select incomplete data analysis….. 
3. Specify a location and name for the output file. 

4. Click OK to generate the report. 
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5 View the report when it opens. 


